Page tree
Skip to end of metadata
Go to start of metadata

1.  Funkcje tutoriala

W tym rozdziale nauczysz się o:

ComponentFeatureDetalis
CFX-PreUser ModeGeneral mode
Analysis TypeTransient Blade Row
Fluid TypeAir Ideal Gas
Domain TypeMultiple Domains
Rotating Frame of Reference
Turbulence Modelk-Epsilon
Heat TransferTotal Energy
Boundary ConditionsIntlet (Subsonic)
Outlet(Subsonic)
Wall (Counter Rotating)
Mesh MotionPeriodic Motion
Sliding Mesh
CFD-PostPlotsContour
Isosurface
Vectors
Transisent Blade Row Expansion

2. Ogólny opis rozwiązywanego problemu

Celem tej instrukcji jest ustawienie symulacji niestacjonarnego ruchu wieńca łopatek za pomocą transformacji Fouriera jako części modelowania zjawiska drgań samowzbudnych łopatek (flatter). Integralnym krokiem dla modelowania flatteru łopatki są obliczenia współczynnika aerodynamicznego tłumienia jako funkcji możliwych średnic węzłowych (promieniowe linie symetrii po całym obwodzie) dla modelowanego komponentu. Jeśli ilość sekcji w komponencie jest liczbą całkowitą i mnożnikiem średnic węzłów, liczba wymaganych w modelu kanałów łopatkowych o zadanej średnicy węzłów może być istotnie zredukowana poprzez wykorzystanie okresowości warunków brzegowych. Eliminuje to konieczność modelowania całego komponentu/układu. Z użyciem transformacji Fouriera liczba wymaganych kanałów może być utrzymana na poziomie minimalnym, tj. dwóch, dla wszystkich średnic węzłów.

Do zilustrowania podstawowych zasad ustawiania problemu instrukcja ta wykorzystuje sprężarkę osiową, przy prowadzeniu i monitorowaniu obliczeń niestacjonarnego ruchu wieńca łopatek wirnika w CFX. Pełna geometria maszyny składa się z jednego wirnika z 36 łopatkami, podobnie jak na rysunku 36.1: Single Row Reference Case Containing 36 Blades (strona 736) pokazanym poniżej:

Rys.1: Pojedynczy rząd łopatek wirnika sprężarki osiowej posiadającego 36 łopatek

Dla niezerowych średnic węzłów istnieje skończony kąt międzyfazowy łopatek (IBPA) pomiędzy sąsiednimi łopatkami. Ta różnica faz pomiędzy łopatkami wyraża się wzorem:

    

 gdzie liczba łopatek zmienia się w zakresie: ND=0...NBL - 1

Poniższa tabela porównuje liczbę kanałów na komponent wymaganą do modelowania zadanej średnicy węzłów z wykorzystaniem okresowości warunków brzegowych lub transformacji Fouriera:

Nodal DiameterIBPA

Number of Passages per Component

to Model

Reference Case

(Rotational Periodicity)

Fourier

Transformations

0012
110362
220182
330122
44092
550362
66062
770362
88092
99042

W tej instrukcji będziesz modelować średnicę węzłów (ND – nodal diameter) dla czterech przybliżeń transformacji Fouriera z ograniczeniem do dwóch kanałów. Równoważny model, wykorzystujący okresowość warunków brzegowych (przypadek referencyjny) wymaga dziewięciu kanałów, tj. ¼ obwodu analizowanego wirnika.

Wirnik maszyny obraca się z prędkością kątową 1800 rad/s. Warunki brzegowe dla wlotu są modelowane poprzez zadaną wartość ciśnienia całkowitego (spiętrzenia) i temperatury spiętrzenia w stacjonarnym układzie, dla przyjętego kierunku przepływu w elemencie cylindrycznym. Wylotowy warunek brzegowy jest zadany jako średnie ciśnienie statyczne równe 138 kPa, zróżnicowane jedynie w kierunku promieniowym. Wlotowe warunki brzegowe są wprowadzane z wykorzystaniem pliku o rozszerzeniu .csv.

Wibracja łopatki modelowana jest przez wymuszony ruch okresowy o stałej częstotliwości przy ściśle określonym kącie międzyfazowym. Częstotliwość oraz odkształcenie profilu (postać modalna) są otrzymywane z obliczeń układu cyklicznej symetrii w ANSYS Mechanical z użyciem modelu łopatki wyeksportowanego do pliku typu .csv. Dla tego przypadku częstotliwość drgań wynosi 1152,13 Hz, a maksymalne odkształcenie danej postaci modalnej wynosi 0,00129 m. W celu użycia tej zmiany kształtu pojedynczej łopatki do symulacji układu wielołopatkowego, profil musi być powtórzony wokół osi maszyny. Ten powielony profil zawiera numer sektora identyfikujący każdy skopiowaną sekcję z oryginalnego profilu. Numer sektora rośnie zgodnie z regułą prawej dłoni wokół osi maszyny. Numer kanału może być wykorzystany do zadania kierunku zmiany fazy; to znaczy, że może definiować rosnący lub malejący kąt teta (kierunek obwodowy) dla odkształceń.

Dla zamodelowania przesuwania się siatki, u wierzchołków łopatek wykorzystywana jest powierzchnia obrotowa  uwzględniająca ruch siatki, a tym samym warunków brzegowych.

Mnożnik kąta fazowego (PAM) ma tą samą wielkość co średnica węzłów (ND), ale ma przeciwny znak. Dodatni PAM wskazuje, że łopatki z wyższym teta przenoszą ruch opóźniony względem innych łopatek o niższej wartości teta. Węzły u powierzchni piasty są zdefiniowane stacjonarnie, podczas gdy węzły powierzchni u wierzchołków mogą podążać za odkształceniem łopatki.

3. Uruchamianie CFX-PRE

  1. Przygotuj katalog roboczy z wykorzystaniem następujących plików z folderu examples:

       2. Ustaw katalog roboczy i uruchom CFX-Pre.

4. Definiowanie przypadku flatter łopatki w CFX-Pre

Ta sekcja opisuje ustawienia symulacji zagadnienia flatteru łopatki w CFX-Pre. Pomimo faktu, że przemieszczenie siatki dla problemu stacjonarnego jest minimalne, zapoznasz się z użyciem warunków początkowych dla transformacji Fouriera w przypadku flatteru łopatki.

  1. W CFX-Pre wybierz File > New Case.
  2. Wybierz General i kliknij OK.
  3. Wybierz File > Save Case As.
  4. W polu File name wprowadź polecenie FourierBladeFlutterIni.cfx.
  5. Kliknij Save.

4.1 Importowanie siatki (Importing the mesh)

  1. W drzewie Outline kliknij prawym przyciskiem myszy na Mesh i wybierz Import Mesh > CFX Mesh. Pojawia się okno dialogowe Import Mesh.
  2. Skonfiguruj następujące ustawienia:

    SettingValue
    File nameR37ATM_60k.gtm
  3. Kliknij Open.
    Plik ten zawiera siatkę dla pojedynczego kanału. Metoda transformacji Fouriera wymaga dwóch kanałów międzyłopatkowych dla dowolnej liczby IBPA.
  4. Kliknij prawym przyciskiem myszy na R37ATM_60k.gtm pod Outline > Mesh, następnie wybierz Transform Mesh (przekształć siatkę).
  5. Pod Mesh Transformation Editor wybierz Transformation > Turbo Rotation.
  6. Skonfiguruj następujące ustawienia:

    SettingValue
    Rotation OptionPrincipal Axis
    AxisZ
    SettingValue
    Passages per Mesh1
    Passages to Model2
    Passages in 36036
  7. Kliknij Apply i zamknij okno dialogowe Mesh Transformation Editor.

4.2 Rozszerzanie danych profilu (Expanding profile data)

Profil opisujący częstotliwość i kształt modalny jej drgań dla jednej łopatki jest załączony do tej instrukcji. Jeśli modelujemy więcej niż jedną łopatkę, profil ten musi być rozbudowany zanim będzie zainicjowany i użyty do specyfikacji warunków brzegowych.

  1. Wybierz Tools > Expand Profile Data.
  2. Pod Data File to Expand kliknij Browse .
  3. Z twojego katalogu roboczego wybierz R37_model_1p.csv.

  4. Pod Write to Profile wprowadź R37_model_36p.csv.
  5. Skonfiguruj następujące ustawienia:
SectionSettingValue
Passage DefinitionPassages in Profile1
Passages in 36036
Rotation AxisGlobal Z

kliknij OK

4.3 Inicjalizacja danych profilu (Initializing profile data)

Funkcje napływu (inflow) i mode1 są zdefiniowane przy pomocy profili znajdujących się w pliku .csv dostarczonym z tą instrukcją. Dane profilu muszą zostać zainicjowane zanim będą one użyte dla potrzeb funkcji napływu i mode1.

  1. Wybierz Tools > Initialize Profile Data.
  2. Pod Data File kliknij Browse .
  3. Z katalogu roboczego wybierz R37_inlet.csv.
  4. Kliknij Open.
  5. Kliknij Apply.

          Warunki napływu są wczytane do pamięci roboczej.

  1. Pod Data File kliknij Browse .
  2. Z katalogu roboczego wybierz R37_model_36p.csv.
  3. Kliknij Open.
  4. Kliknij OK.

4.4 Tworzenie domeny (Creating the domain)

Domena płynu używana dla tej symulacji zawiera powietrze, jako gaz idealny. W związku z tym musisz również ustawić ruch siatki dla łopatek.

  1. Wybierz Insert > Domain z głównego menu.
  2. W oknie dialogowym Insert Domain wprowadź R1.
  3. Kliknij OK, aby stworzyć nową domenę.
  4. Skonfiguruj następujące ustawienia:
TabSettingValue
Basic Settings

 

 

 

 

Location and Type

> Location

Entire Rotor Passage

Fluids and Particle Definitions...

 

> Fluid 1

 

> Material

Air Ideal GasDomain Models

Domain Models

> Reference Pressure

0 [Pa]

Domain Models

 

>Domain Motion

>Option

Rotating

Domain Models

>Domain Motion

>Angular Velocity

-1800 [radians s^-1]

Domain Models

 

> Domain Motion

> Alternate Rotation Model
(Selected)

Domain Models

 

> Mesh Deformation

> Option
Regions of Motion Specified

Domain Models

 

> Mesh Deformation

> Displacement Relative To
Initial Mesh

Domain Models

 

> Mesh Deformation

> Mesh Motion Model

> Option
Displacement Diffusion

Domain Models

 

> Mesh Deformation

> Mesh Motion Model

> Mesh Stiffness

> Option
Value

Domain Models

 

> Mesh Deformation

> Mesh Motion Model

> Mesh Stiffness

1 [m^2 s^-1]*(1.0E-6 [m^3] / Volume of Finite Volumes)^2

[2] [3]
Fluid Models

Heat Transfer

 

> Option
Total Energy
  1. Zauważ, że ujemna wartość prędkości kątowej jest używana ze względu na obrót maszyny zgodnie z ruchem wskazówe zegara względem osi obrotu.
  2. Wyrażenie dla sztywności siatki oparte na wielkości objętości kontrolnej jest wprowadzone w celu poprawy odporności siatki na płynność algorytmów siatki .
  3. Kliknij  ikonę Enter Expression , aby określić wyrażenie CEL

Kliknij OK

4.5 Tworzenie granic

4.5.1 Granica wlotu

1. Utwórz nową granicę nazwaną R1 Inlet.

2. Skonfiguruj następujące ustawienia:

TabSettingValue
Basic SettingsBoundary TypeInlet
LocationEntire Rotor IN-FLOW
Frame TypeStationary

Profile Boundary Conditions

 

> Use Profile Data
(Selected)

Profile Boundary Conditions

 

> Profile Boundary Setup

> Profile Name

Inflow

 3. Kliknij Generate Values.

 4. Skonfiguruj następujące ustawienia:

TabSettingValue
Boundary Details

Mesh Motion

 

> Option
Stationary

Mass and Momentum

 

> Option
Stat. Frame Tot. Press.

Mass and Momentum

 

> Relative Pressure
Inflow.Total Pressure(r)[1]

Flow Direction

 

> Option
Cylindrical Component

Flow Direction

 

> Axial Component
Inflow.Velocity Axial(r)[1]

Flow Direction

 

> Radial Component
Inflow.Velocity Radial(r)[1]

Flow Direction

 

> Theta Component
Inflow.Velocity Circumferential(r)[1]

Flow Direction

 

> Theta Component
Medium (Intensity = 5%)

Heat Transfer

 

> Option
Stat. Frame Total Temp.

Heat Transfer

 

> Stat. Frame Total Temp.
Inflow.Total Temperature(r)[1]


5. Kliknij ikonę Enter Expression, aby określić wyrażenie CEL.

6. Kilknij OK.

4.5.2 Granica wylotu

  1. Stwórz nową granicę nazwaną R1 Outlet.
  2. Skonfiguruj następujące ustawienia:

     

    TabSettingValue
    Basic SettingsBoundary TypeOutlet
    LocationEntire Rotor OUTFLOW
    Frame TypeStationary
    Boundary Details

    Mesh Motion

    > Option
    Stationary

    Mass and Momentum

    > Option
    Average Static Pressure

    Mass and Momentum

    > Relative Pressure
    138 [kPa]

    Mass and Momentum

    > Pres. Profile Blend
    1

    Pressure Averaging

    > Option
    Radial Equilibrium

    Pressure Averaging

    > Radial Reference Position

    > Option
    Specified Radius

    Pressure Averaging

    > Radial Reference Position

    > Specified Radius
    0.215699 [m]
  3. Kliknij OK.

 

4.5.3 Granica na ściankach

Piasta wirnika (hub) i obudowa zewnętrzna (shroud) oraz łopatka w obszarze płynu wymagają określenia brzegu w postaci ścianki.

  1. Stwórz nową granicę nazwaną R1 Hub .
  2. Skonfiguruj następujące ustawienia:

    TabSettingValue
    Basic SettingsBasic SettingsWall
    LocationEntire Rotor HUB
    Frame TypeRotating
    Boundary Details

    Mesh Motion

    > Option
    Stationary
  3. Kliknij OK.
  4. Stwórz nową granicę nazwaną R1 Shroud.
  5. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Boundary Type

    Wall

    Location

    Entire Rotor BLADE

    Frame Type

    Rotating

    Profile Boundary Conditions

    > Use Profile Data

    (Selected)

    Profile Boundary Conditions

    > Profile Boundary Setup

    > Profile Name

    mode1

    Boundary Details

    Mesh Motion

    > Option

    Stationary

  6. Kliknij OK.
  7. Utwórz nową granicę nazwaną R1 Blade .
  8. Skonfiguruj następnie ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Boundary Type

    Wall

    Location

    Entire Rotor BLADE

    Frame Type

    Rotating

    Profile Boundary Conditions

    > Use Profile Data

    (Selected)

    Profile Boundary Conditions

    > Profile Boundary Setup

    > Profile Name

    mode1

    Boundary Details

    Mesh Motion

    > Option

    Stationary

  9. Kliknij OK.

4.6 Tworzenie Interfejsu domeny

Teraz utworzysz parę interfejsów w domenie płyn-płyn wzdłuż szczeliny wierzchołkowej (tip gap) dla każdej łopatki.

  1. Kliknij Insert > Domain Interface i w wyświetlonym oknie dialogowym ustaw wartość Name na R1 Blade Tip Gap.
  2. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

     

     

     

     

    Interface Type

    Fluid Fluid

    Interface Side 1

    > Domain (Filter)

    R1

    Interface Side 1

    > Region List

    Rotor SHROUD TIP GGI SIDE 1

    Interface Side 2

    > Domain (Filter)

    R1

    Interface Side 2

    > Region List

    Rotor SHROUD TIP GGI SIDE 2

    Interface Models

    > Option

    General Connection

    Mesh Connection

    Interface Connection Method

    > Mesh Connection

    > Option

    GGI

  3. Kliknij OK.
  4. Kliknij Insert > Domain Interface i w wyświetlonym oknie dialogowym ustaw wartość Name na R1 Blade Tip Gap 2.
  5. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Interface Type

    Fluid Fluid

    Interface Side 1

    > Domain (Filter)

    R1

    Interface Side 1

    > Region List

    Rotor SHROUD TIP GGI SIDE 1 2

    Interface Side 2

    > Domain (Filter)

    R1

    Interface Side 2

    > Region List

    Rotor SHROUD TIP GGI SIDE 2 2

    Interface Models

    > Option

    General Connection

    Mesh Connection

    Interface Connection Method

    > Mesh Connection

    > Option

    GGI

  6. Kliknij OK.
  7. Kliknij Insert > Domain Interface i w wyświetlonym oknie dialogowym ustaw wartość Name na R1 to R1 Periodic.
  8. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Interface Type

    Fluid Fluid

    Interface Side 1

    > Domain (Filter)

    R1

    Interface Side 1

    > Region List

    Rotor PER1

    Interface Side 2

    > Domain (Filter)

    R1

    Interface Side 2

    > Region List

    Rotor PER2

    Interface Models

    > Option

    Rotational Periodicity

    Interface Models

    > Axis Definition

    > Option

    Coordinate Axis

    Interface Models

    > Axis Definition

    > Rotation Axis

    Global Z

    Mesh Connection

    Interface Connection Method

    > Mesh Connection

    > Option

    GGI

  9. Kliknij OK.

    W odniesieniu do dwóch interfejsów płyn-płyn, metoda transformacji Fouriera wymaga interfejsu domeny pomiędzy dwoma kanałami. Ta metoda interfejsu będzie użyta przez transformację Fouriera do zebrania informacji o przepływie. Dane będą przeniesione z powrotem do okresowych warunków na brzegach z odpowiednim opóźnieniem czasowym.

    Uwaga

    Okresowe i przykładowe interfejsy muszą korzystać z połączenia siatki GGI

  10. Kliknij Insert > Domain Interface i w wyświetlonym oknie dialogowym ustaw wartość Name na R1 Sampling Interface.
  11. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Interface Type

    Fluid Fluid

    Interface Side 1

    > Domain (Filter)

    R1

    Interface Side 1

    > Region List

    Rotor PER2

    Interface Side 2

    > Domain (Filter)

    R1

    Interface Side 2

    > Region List

    Rotor PER1 2

    Interface Models

    > Option

    General Connection

    Mesh Connection

    Interface Connection Method

    > Mesh Connection

    > Option

    GGI

  12. Kliknij OK.

Odwzorowania warunków brzegowych okresowej transformacji Fouriera są związane z ruchem siatki zastosowanym do interfejsu okresowego. Możesz uniknąć tego poprzez zmianę opcji ruchu siatki dla Periodic i Sampling na stacjonarną.

  1. W drzewie (Outline Three) edytuj: R1 to R1 Periodic Side 1, pod: Flow Analysis 1 > R1.
  2. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Boundary Details

    Mesh Motion

    > Option

    Stationary

  3. Kliknij OK.
  4. Powtórz krok 2 dla następujących deklaracji: R1 to R1 Periodic Side 2, R1 Sampling Interface Side 1, R1 Sampling Interface Side 2.

4.7 Tworzenie pliku solvera CFX-Solver Input (.def) File

  1. Kliknij Write Solver Input File .
  2. Skonfiguruj następujące ustawienia:

    Setting

    Value

    File Name

    FourierBladeFlutterIni.def

  3. Kliknij Save.
  4. Zapisz symulację.

5. Definiowanie transformacji Fouriera dla przypadku flatteru łopatki w CFX-Pre

W tej drugiej części instrukcji będziesz modyfikować symulację stacjonarną z części pierwszej w celu zamodelowania nieustalonego ruchu wieńca łopatek. Wyniki ze stacjonarnej symulacji są użyte jako pierwsze przybliżenie w celu przyspieszenia zbieżności symulacji.

Jeśli masz zamiar rozpocząć symulację automatycznie używając pliku instrukcji tutoriala, uruchom: FourierBladeFlutter.pre. Szczegóły jego uruchamiania znajdziesz na stronie 6: Playing a Tutorial Session File. Następnie przejdź do strony 758: Obtaining a Solution to the Transient Blade Row Case.

5.1 Otwieranie istniejącego przypadku

Krok ten obejmuje otwarcie oryginalnej symulacji i zapisanie jej pod inną lokalizacją.

  1. Jeśli CFX-Pre nie jest otwarty, uruchom go.
  2. Jeśli oryginalna symulacja nie jest otwarta, otwórz: FourierBladeFlutterIni.cfx.
  3. Zapisz ją, jako: FourierBladeFlutter.cfx w katalogu roboczym.

5.2 Modyfikowanie typu analizy

Zmodyfikuj typ analizy w następujący sposób:

  1. Edytuj: Analysis Type.
  2. Skonfiguruj następujące ustawienia:

    Setting

    Value

    Analysis Type

    > Option

    Transient Blade Row

  3. Kliknij OK.

5.3 Modyfikowanie domeny

 

Zmodyfikuj domenę w następujący sposób:

  1. Edytuj: R1 w drzewie: Outline, pod: Flow Analysis 1.
  2. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Passage Definition

    > Pass. in Component

    2

    Passage Definition

    > Passages in 360

    36

  3. Kliknij OK.

5.4 Tworzenie wyrażeń dla częstotliwości i współczynnika skali

Następnym krokiem jest utworzenie wyrażeń definiujących częstotliwość (Frequency), maksymalne przemieszczenie okresowe (Maximum periodic displacement) oraz współczynnik skali (Scaling factor), które będą użyte w definicji brzegów łopatki.

  1. Z głównego menu wybierz: Insert > Expressions, Functions and Variables > Expression.
  2. W oknie dialogowym: Instert Expression wprowadź: VibrationFrequency.
  3. Kliknij OK.
  4. Ustaw wartość: Definition na poziomie 1152.13 [Hz].
  5. Kliknij: Apply, aby stworzyć wyrażenie.

Utworzysz wyrażenie definiujące maksymalne przemieszczenie okresowe.

  1. Utwórz wyrażenie nazwane: MaxPeriodicDisplacement.
  2. Ustaw wartość: Definition na: 0.0015 [m].
  3. Kliknij Apply.

5.5 Modyfikowanie Granicy łopatki R1

  1. Edytuj: R1 Blade w drzewie: Outline, pod: Flow Analysis 1.
  2. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Boundary Type

    Wall

    Location

    Entire Rotor BLADE

    Frame Type

    Rotating

    Profile Boundary Conditions

     

    > Use Profile Data

    (Selected)

    Profile Boundary Conditions

     

    > Profile Boundary Setup

    > Profile Name

    mode1

  3. Kliknij: Generate Values.
  4. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Boundary Details

    Mesh Motion

     

    > Option

    Periodic Displacement

    Mesh Motion

     

    > Periodic Displacement

    > Option

    Cartesian Components

    Mesh Motion

     

    > Periodic Displacement

    > X Component

    mode1.meshdisptot x(Initial X,Initial Y,Initial Z)

    Mesh Motion

     

    > Periodic Displacement

    > Y Component

    mode1.meshdisptot y(Initial X,Initial Y,Initial Z)

    Mesh Motion

     

    > Periodic Displacement

    > Z Component

    mode1.meshdisptot z(Initial X,Initial Y,Initial Z)

    Mesh Motion

     

    > Periodic Displacement

    > Frequency

    VibrationFrequency [1]

    Mesh Motion

     

    > Periodic Displacement

    > Scaling

    ScalingFactor [1]

    Mesh Motion

     

    > Periodic Displacement

    > Phase Angle

    > Option

    Phase Angle Multiplier

    Mesh Motion

     

    > Periodic Displacement

    > Phase Angle

    > Phase Angle Multiplier

    4

    Mesh Motion

     

    > Periodic Displacement

    > Phase Angle

    > Passage Number

    Mode1.Sector

    Tag(Initial X,Initial Y,Initial Z)

    1. Kliknij ikonę Enter Expression , aby określić wyrażenie CEL.

  5. Kliknij OK.

5.6 Ustawienia nieustalonego modelu wieńca łopatek (Transient blade row model)

W tej sekcji będziesz ustawiać rozwiązanie symulacji z użyciem metody transformacji Fouriera.

  1. Stwórz nowy obiekt wieńca łopatek wybierając: Insert > Transient Blade Row Models z głównego menu.
  2. Skonfiguruj następujące ustawienia:

    Setting

    Value

    Transient Blade Row Model

     

    > Option

    Fourier Transformation

  3. Pod Fourier Transformation kliknij ikonę Add new item , zaakceptuj nazwę domyślną I kliknij OK.
  4. Skonfiguruj następujące ustawienia:

     

    Setting

    Value

    Fourier Transformation 1

     

    > Option

    Blade Flutter

    Fourier Transformation 1

     

    > Phase Corrected Intf.

    R1 to R1 Periodic

    Fourier Transformation 1

     

    > Sampling Domain Intf.

    R1 Sampling Interface

    Fourier Transformation 1

     

    > Blade Boundary

    R1 Blade

    Transient Details

     

    > Time Period

    > Option

    Value

    Transient Details

     

    > Time Period

    > Period

    1/VibrationFrequency[1]

    Transient Details

     

    > Time Steps

    > Option

    Number of Timesteps per Period

    Transient Details

     

    > Time Steps

    > Timesteps/Period

    64[2]

    Transient Details

     

    > Time Duration

    > Option

    Number of Periods per Run

    Transient Details

     

    > Time Duration

    > Periods per Run

    10

    1. Kliknij ikonę Enter Expression , aby określić wyrażenie CEL.

    2. Liczba kroków czasowych jest wielokrotnością 2 i wartości mnożnika kąta fazowego (Phase Angle Multiplier). Gwarantuje to, że obie łopatki będą osiągać te same deformacje w przeciągu okresu.

  5. Kliknij OK.

5.7 Ustawienia kontroli danych wyjściowych i tworzenie punktów monitorowania

W tej sekcji będziesz tworzyć punkty monitorowania całkowitych parametrów przepływu i przemieszczeń siatki. Punkty monitorowania dostarczają przydatnych informacji o jakości etapu referencyjnego oraz częstotliwości otrzymanej w wyniku symulacji. Punkty te powinny również służyć kontroli zbieżności i wzorców wypracowanych przez symulację.

Uwaga

  • Podczas porównywania wykresu transformacji Fouriera do przypadku referencyjnego upewnij się, że punkty monitorowania w obu przypadkach są umieszczone relatywnie w tej samej lokalizacji względem konfiguracji początkowej.
  • Monitorowanie ciśnienia i prędkości dostarcza dane do równania zachowania pędu, podczas gdy monitorowanie temperatury wprowadza dane do równania energii. Punkty monitorowania pomagają sprawdzić poprawność rozwiązywania równań przez solver.

Ustaw solver na wyniki nieustalone, aby przeanalizować narzucone wartości przemieszczeń siatki. Analiza niestacjonarna wieńca łopatek oferuje metodę kompresji Fouriera w celu gromadzenia okresowych danych.

  1. Kliknij: Output Control .
  2. Kliknij etykietę: Trn Results.
  3. Skonfiguruj następujące ustawienia:

    Setting

    Value

    Transient Blade Row Result

    > Extra Output Variables List

    (Selected)

    Transient Blade Row Results

    > Extra Output Var. List

    Total Pressure, Total Temperature, Total Mesh Displacement, Wall Work Density, Wall Power Density

  4. Kliknij: Apply.
  5. Kliknij etykietę: Monitor.

    Dla tej symulacji będziesz ustawiać dwa typy punktów monitorowania. Najpierw ustawisz punkty  monitorowania dla kontroli zmiennych we właściwych współrzędnych cylindrycznych wewnątrz domeny. Współrzędne cylindryczne są przydatne w aplikacjach dla maszyn wirnikowych, ponieważ pozwalają ulokować punkty monitorowania w relatywnie tym samym położeniu wewnątrz różnych kanałów poprzez zmianę składowej teta przez równoważną podziałkę kanału międzyłopatkowego. Po drugie, punkty monitorowania będą służyć kontroli wartości określanych z równań.

  6. Wybierz: Monitor Objects.
  7. Skonfiguruj następujące ustawienia:

    Setting

    Value

    Monitor Objects

    > Monitor Points and Expressions

    Create a monitor point named LE1pass1 [1]

    Monitor Objects

    > Monitor Points and Expressions

    > LE1pass1

    > Option

    Cylindrical Coordinates

    Monitor Objects

    > Monitor Points and Expressions
    > LE1pass1

    > Output Variables List

    Pressure, Temperature, Total Pressure, Total Temperature, Velocity, Velocity in Stn Frame [2]

    Monitor Objects

    > Monitor Points and Expressions

    > LE1pass1

    > Output Variables List

    > Cylindrical Coordinates

    (0 [m], 0.23 [m], -7.49472 [degree])

     1. Aby stworzyć nowy punkt kliknij ikonę Add new item , a następnie wprowadź wymaganą nazwę i kliknij OK.

     2. Kliknij ikonę Multi-select from extended list  i przytrzymaj klawisz Ctrl podczas zaznaczania każdej z wypisanych zmiennych.

  8. Kliknij Apply.
  9. Stwórz dodatkowe punkty monitorowania z tymi samymi zmiennymi wyjściowymi. Nazwy i współrzędne cylindryczne podane są w tabeli:

    Setting

    Value

    LE1pass2

    (0 [m], 0.23 [m], 2.50528 [degree])

    LE2pass1

    (0 [m], 0.23 [m], -2.49472 [degree])

    LE2pass2

    (0 [m], 0.23 [m], 7.50528 [degree])

    TE1pass1

    (0 [m], 0.23 [m], -0.011463 [degree])

    TE1pass2

    (0 [m], 0.23 [m], 9.794967 [degree])

    TE2pass1

    (0 [m], 0.23 [m], 4.988537 [degree])

    TE2pass2

    (0 [m], 0.23 [m], 14.794967 [degree])

  10. Kliknij: Apply na każdym punkcie monitorowania.
  11. Utwórz dodatkowe punkty monitorowania z następującymi wyrażeniami:

    Setting

    Value

    Force on Blade

    force()@REGION:Rotor BLADE

    Force on Blade 2

    force()@REGION:Rotor BLADE 2

    Max Displ Blade

    maxVal(Total Mesh Displacement)@REGION:Rotor BLADE

    Max Displ Blade 2

    maxVal(Total Mesh Displacement)@REGION:Rotor BLADE 2

    Power on Blade

    areaInt(Wall Power Density)@REGION:Rotor BLADE

    Power on Blade 2

    areaInt(Wall Power Density)@REGION:Rotor BLADE 2

    Work on Blade

    areaInt(Wall Work Density)@REGION:Rotor BLADE

    Work on Blade 2

    areaInt(Wall Work Density)@REGION:Rotor BLADE 2

  12. Kliknij OK

5.8 Tworzenie pliku danych solvera CFX-Solver Input (.def) File

  1. Kliknij: Write Solver Input File .
  2. Skonfiguruj następujące ustawienia:

    Setting

    Value

    File Name

    FourierBladeFlutter.def

  3. Kliknij Save.

6. Otrzymywanie rozwiązania dla przypadku stacjonarnego (Steady-state case)

  1. Wybierz: File > Define Run.
    Wyświetla się okno dialogowe: Define Run.
  2. Pod: Solver Input File, kliknij: Browse  i wybierz: FourierBladeFlutterIni.def.
  3. Wybierz: Double Precision (podwójna precyzja).
  4. Kliknij: Start Run.CFX-Solver uruchamia się i stara się otrzymać rozwiązanie.
    Na końcu, po uruchomieniu wyświetla się okno dialogowe informujące o zakończeniu symulacji.
  5. Wyczyść zawartość: Post-Process Results.
  6. Kliknij: OK.

7. Otrzymywanie rozwiązania przypadku niestacjonarnego wieńca łopatek (Transient blade row)

Aby zredukować czas symulacji dla analizy flatteru łopatki, symulacja będzie zainicjowana z użyciem przypadku stacjonarnego (Steady-state).

 

  1. Kliknij: File > Define Run.
  2. Pod: Solver Input File, kliknij: Browse  i wybierz: FourierBladeFlutter.def.
  3. Wybierz: Run Definition > Initial Values Specification.
  4. Pod: Initial Values Specification > Initial Values, wybierz: Initial Values 1.
  5. Pod: Initial Values Specification > Initial Values > Initial Values 1 Settings > File Name, kliknij: Browse .
  6. Wybierz FourierBladeFlutterIni_001.res z katalogu roboczego.
  7. Kliknij Open.
  8. Ustaw wartość Initial Values Specification > Use Mesh From na Solver Input File.
  9. Wybierz: Double Precision.
  10. Kliknij: Start Run.

    CFX-Solver uruchamia się i stara się otrzymać rozwiązanie. Może to zająć dużo czasu w zależności od twojego systemu. Na końcu może się wyświetlać okno dialogowe.

Uwaga

      • Zanim rozpocznie się symulacja, w pliku: „Transient Blade Row Post-Processing Information” z roszerzeniem .out, wyświetli zakres kroku czasowego, z którym solver będzie gromadził współczynniki Fouriera. Szczegóły znajdziesz w: Post–processing Information zawarte w poradniku: CFX-Solver Manager User’s Guide.
      • Podobnie, podsumowanie: „Fourier Trafnsformation Stability” w pliku typu .out wyświetli krok czasowy, z jakim jest aktywowany pełny model transformacji Fouriera.
    • Punkty monitorowania o zbliżonych wartościach mogą być grupowane poprzez kliknięcie prawym przyciskiem myszy na etykietę: User Point, wybranie: New Monitor i kliknięcie: OK. W oknie dialogowym: New Monitor możesz ustawić nazwę nowego punktu monitorowania i wybrać zmienne jakie chcesz kontrolować w oknie dialogowym: Monitor Properties.
    • Symulacja powinna być wykonywana do momentu osiągnięcia okresowości wartości punktów monitorowania.

Możesz zaobserwować ewolucję określonych wyrażeń. Siły działające na każdą łopatkę mogą zostać wykreślone z uwzględnieniem jej przemieszczenia. W tym celu:

  1. Wybierz: Workspace > New Monitor i zaakceptuj nazwę domyślną.
  2. Pod: Plot Lines rozwiń drzewo: USER POINT i wybierz: Work on Blade.
  3. Kliknij: Apply.
  4. Pod etykietą: Range Settings wybierz: Simulation Time w sekcji: Plot Data By.

To wyświetli historię czasu symulacji pracy na łopatce 1.

Możesz powtórzyć ten proces dla łopatki 2 poprzez zastąpienie zmiennych: Work on Blade deklarując: Work on Blade 2.

   11. Kiedy CFX-Solver zakończy pracę wybierz okienko obok Post-Procesor Results.

   12. kliknij OK

 

8.  Podgląd wyników transformacji Fouriera flatteru łopatki w CFD-Post

Niestacjonarna analiza obliczeniowa wieńca łopatek daje szereg dodatkowych zmiennych w rozwiązaniu  w porównaniu do tych, które dodano w: Setting Output Control and Creating Monitor Points (strona 754). Te zmienne są skompresowane przy użyciu dyksretnej transformacji Fouriera, a odnoszące się do nich współczynniki są gromadzone w pliku z wynikami. CFD-Post pozwala rozwinąć te transformacje na interesujące nas wartości zmiennych w wybranej chwili czasu. Selektor kroków czasowych pokaże chwilowe parametry, które są reprezentatywne dla wartości użytych przez solver. Ponadto, gdy stanie się to konieczne, w odniesieniu do istniejących wartości czasowych mogą być dodane lub usunięte dodatkowe wartości czasowe.

W tej sekcji stworzysz kilka wykresów ilustrujących wykorzystanie selektora kroków czasowych dla analizy przejściowej wieńca łopatek. Ponadto, stworzysz zdefiniowaną przez użytkownika zmienną dla pracy całej ścianki i użyjesz tej zmiennej do stworzenia konturu i animacji ruchu łopatki.

Aby rozpocząć wykonaj poniższe kroki:

  1. Kiedy CFD-Post się uruchomi, możesz zobaczyć informację odnoszącą się do Transient Blade Row postprocessing (przejściowy ruch łopatek – postprocessing), kliknij: OK.
  2. Możesz też zobaczyć okno dialogowe: Domain Selector. Jeśli tak, upewnij się, że wszystkie domeny zostały wybrane i kliknij: OK.

8.1 Wyświetlanie całkowitej pracy na ściance łopatki (Total wall work on the blade)

  1. Wybierz: Insert > Variable i ustaw nazwę na: Total Wall Work.
  2. Skonfiguruj następujące ustawienia:

    Name

    Setting

    Value

    Total Wall Work

    Method

    Expression

    Scalar

    (Selected)

    Expression

    Wall Work Density * Area

    Calculate Global Range

    (Selected)



  3. Kliknij: Apply, aby utworzyć nową zmienną.

Możesz przejrzeć zmienną: Total Wall Work w etykiecie: Variables, pod: User Defined.

8.2 Tworzenie wykresu konturowego dla całkowitej pracy na ściance łopatki

  1. Kliknij: Insert > Contour i zaakceptuj nazwę domyślną.
  2. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    Geometry

    Locations

    R1 Blade

    Variable

    Total Wall Work

    Range

    Local

    # of Contours

    21

    Render

    Show Contour Lines

    (Selected)

    Constant Coloring

    (Selected)

    Color Mode

    Default

  3. Kliknij: Apply.

    Wykres konturowy pokazuje chwilowe wartości dla Total Wall Work.

8.3 Tworzenie animacji całkowitej pracy na ściance łopatki

Używając wykresu konturowego stworzonego wcześniej, teraz utworzysz animację dla łopatki dla pierwszej fazy.

  1. Korzystając z okna dialogowego: Timestep Selector upewnij się, że wybrana jest wartość czasu równa 0[s].
  2. Pod: Timestep Sampling wybierz: Uniform.
  3. Wybierz: Tools > Animation lub kliknij: Animation .Pojawia się okno dialogowe Animation.
  4. Wybierz: Keyframe Animation (animacja kluczowa).
  5. Kliknij New  aby utworzyć KeyframeNo1.
  6. Podświetl: KeyframeNo1, a następnie zmień: #of Frames na wartość 48.
  7. Wybierz krok czasowy dla pierwszej fazy (krok czasowy numer 32) korzystając z okna dialogowego Timestep Selector.
  8. Kliknij New  , aby stworzyć KeyframeNo2.
    Parametr # of Frames nie ma wpływu na ostatnią klatkę kluczową, pozostaw wartość domyślną.

  9. Wybierz: Save Movie.

  10. Ustaw: Format na MPEG1.

  11. Kliknij: Browse  obok: Save Movie, aby ustawić ścieżkę i nazwę dla filmu.

    Jeśli ścieżka nie jest podana, plik zostanie zapisany w lokalizacji, z której został uruchomiony CFD-Post.

  12. Kliknij: Save.

    Nazwa filmu (łącznie ze ścieżką) będzie ustawiona, ale film nie został jeszcze utworzony.

  13. Jeśli klatka 1 nie jest załadowana (pokazane w okienku tekstowym F: na środku okna dialogowego Animation), żeby ją załadować kliknij: To Beginning .

    Zaczekaj, aż CFD-Post zakończy ładowanie obiektów dla tej klatki przed kolejnym krokiem.

  14. Kliknij: Play the animation .

    Zostanie utworzony film w czasie jak będzie się odtwarzać animacja. Będzie to dość powolne, ponieważ musi być załadowany krok czasowy, a obiekty muszą zostać utworzone dla każdej klatki z osobna. Aby odtworzyć plik z filmem potrzebujesz skorzystać z odtwarzacza obsługującego format MPEG.

  15. Zapisz wyniki przez wybranie File > Save Project z głównego menu.

 

  • No labels