Page tree
Skip to end of metadata
Go to start of metadata

Przepływ przez stopień turbiny osiowej

Tutorial zawiera:

1 Opis tutorialu

W tym tutorialu opisano :

  • użycie Turbo Wizard w CFX-Pre, by móc szybko określić jego zastosowanie dla maszyn przepływowych,
  • zastosowanie wielu układów odniesienia i uogólnionej siatki interfejsu,
  • zastosowanie interfejsu nieruchomego wirnika pomiędzy domenami wirnika i kierownic,
  • modyfikacje istniejących symulacji,
  • przygotowanie obliczeń chwilowych wartości,
  • użycie warunków dla chwilowych wartości interfejsu wirnik-kierownice do zastąpienia interfejsu nieruchomego wirnika,
  • tworzenie chwilowej animacji pokazującej ruch domen w CFD-Post.

    Component

    Feature

    Detalis

    CFX-Pre

    User Mode

    Turbo Wizard

    Analysis Type

    Steady State

    Transient

    Fluid Type

    Ideal Gas

    Domain Type

    Multiple Domain

    Rotating Frame of Reference

    Turbulence Model

    k-Epsilon

    Heat Transfer

    Total Energy

    Boundary Conditions

    Inlet(Subsonic)

    Outlet(Subsonic)

    Wall:No-Slip

    Wall:Adiabatic

    Domain Interfaces

    Frozen Rotor

    Periodic

    Transient Rotor Stator

    Timestep

    Physical Time Scale

    Transient Example

    Transient Results File

     

    CFX-Solver Manager

    Restart

     

    Parallel Processing

     

    CFD-Post

    Plots

    Animation

    Isosurface

    Surface Group

    Turbo Post

     

    Other

    Changing the Color Range

    Chart Creation

    Instancing Transformation

    Movie Generation

    Quantitative Calculation

    Time Step Selection

    Transient Animation

2 Przegląd problemów do rozwiązania

Celem tego tutorialu jest utworzenie przykładowego toku obliczeń (chwilowych wartości) dla stopnia turbiny osiowej.

Stopień osiowy turbiny akcyjnej posiada 60 łopatek kierownic oraz 113 łopatek wirnika. Rysunek pokazuje połowę obwodu całej geometrii. Etykiety napływu (Inlet) i odpływu (Outlet) pokazują na Rys.1 lokalizację  sekcji: Podsekcje geometrii układu stopnia turbiny. Poniżej pokazano szkic części geometrii stopnia z zaznaczeniem obudowy zewnętrznej (Shroud), podstawy łopatek (Hub), osi obrotu wirnika (Axis of Rotation) oraz przyjętego układu współrzędnych kartezjańskich. 



Geometria, która ma być zamodelowana zawiera pojedynczy rząd łopatek kierownic i dwa rzędy łopatek wirnika. Jest to przybliżenie całkowitej geometrii, gdy stosunek liczby łopatek wirnika do łopatek kierownic jest bliski 2:1. W rzędzie kierownic, została zamodelowana 6 -stopniowa sekcja (3600/60 łopatek = 60), podczas gdy dla 2 rzędów wirnika została zamodelowana 6,372 -stopniowa sekcja (2*3600/113 łopatek = 6,3720). Stwarza to stosunek „pitchu”(najmniejszej odległości) pomiędzy interfejsem kierownic i wirnika równy 0,942. Gdy przepływ przecina interfejs, jest on skalowany, aby umożliwić zamodelowanie takiego typu geometrii. Jego rezultatem jest przybliżenie napływu do rzędu wirnika. Co więcej, przepływ przez interfejs nie będzie ciągły z powodu zastosowanego skalowania.

Należy się zawsze starać, aby stosunek „pitchu” był jak najbliższy 1, aby zminimalizować przybliżenia, ale musi to być zrównoważone z obliczeniami komputerowymi. Można przeprowadzić pełną analizę maszyny (zamodelować cały wirnik i łopatki kierownic), co wyeliminuje zmianę „pitchu”, ale wymagać będzie długiego czasu obliczeń. Dla tej geometrii, oraz ¼ obwodu maszyny (28 łopatek wirnika, 15 łopatek kierownicy), zmiana „pitchu” wyniesie 1.009 (1.07?), ale wymaga to modelu 15 razy większego niż omawiany tu przykład w tutorialu.

W tym przykładzie wirnik obraca się z prędkością kątową 523,6 [rad/s] wokół osi Z, a kierownice są nieruchome. Okresowe granice zastosowane  są po to, aby można było modelować tylko małą część całej geometrii.

Istotne parametry termodynamiczne czynnika dla analizowanego problemu:

 - ciśnienie całkowite = 0,265 bar,

 - ciśnienie statyczne = 0,0662 bar,

 - temperatura całkowita = 328,5 K.





Ogólne rozwiązanie tego problemu polega najpierw na zdefiniowaniu symulacji nieruchomego wirnika używając Turbomachinery wizard. Siatka obliczeniowa dla wirnika utworzona w CFX-TASC flow, będzie następnie importowana i połączona z drugą siatką dla kierownic, która jest utworzona w CFX-Mesh. Rezultaty obliczeń będzie można oglądać używając Turbo-Post. Istniejąca symulacja nieruchomego wirnika zostanie zmodyfikowana, aby zdefiniować symulację wirnika z kierownicami dla wartości chwilowych. Symulacja wirnika z kierownicami dla wartości chwilowych zostanie wykonana przy użyciu stanu ustalonego dla nieruchomego wirnika jako rozwiązanie początkowe . Ostatecznie, animacja dla wartości chwilowych pokazująca ruch domen, będzie utworzona w CFD-Post.

3 Zanim zaczniesz

Jeśli jest to pierwszy tutorial, z którym pracujesz ważnym jest, aby powtórzyć sobie następujące tematy zanim rozpoczniesz, są to:

  • Ustawianie katalogu roboczego i uruchamianie ANSYS CFX w trybie autonomicznym.
  • Korzystanie z ANSYS CFX Tutorials używając ANSYS Workbench.
  • Zmiana wyświetlanych kolorów.
  • Odtwarzanie plików tutorialowych.

4 Przygotowanie projektu

Przygotuj katalog roboczy używając następujących plików z katalogu przykładów:

Aby zobaczyć szczegóły, patrz: Przygotowanie katalogu roboczego.

  1. Utwórz katalog roboczy i włącz CFX-Pre.

Aby poznać szczegóły zobacz: Ustawianie katalogu roboczego i uruchamianie ANSYS CFX w trybie autonomicznym.

5 Symulacja stopnia turbiny z nieruchomym wirnikiem

Najpierw należy utworzyć symulację z nieruchomym wirnikiem.

5.1 Definiowanie przypadku używając CFX-Pre


Jeśli chcesz utworzyć symulację automatycznie używając pliku tutorialowego, uruchom AxialIni.pre.

Aby zobaczyć szczegóły, kliknij: Odtwarzanie plików tutorialowych. Następnie przejdź do: Uzyskanie rozwiązania używając CFX-Solver Manager.

W przeciwnym razie, symulacja zostanie utworzona ręcznie przy użyciu kreatora Turbomachinery wizard w CFX-Pre. Tryb przetwarzania wstępnego (pre-processing mode) ma na celu uproszczenie konfiguracji symulacji maszyn przepływowych.

  1. W CFX-Pre wybierz: File > New case
  2. Wybierz Turbomachinery i kliknij OK.
  3. Wybierz File>Save Case As.
  4. Pod File name, napisz: AxialIni.
  5. Kliknij Save.

5.1.1. Podstawowe ustawienia

  1. W panelu Basic settings, zmień ustawienia:

    SettingValue
    Machine TypeAxial Turbine
    Analysis Type> TypeSteady State
  2. Kliknij Next

5.1.2. Definicja komponentów

Dwa nowe komponenty są tu wymagane. Kiedy są one utworzone, siatki będą importowane.

  1. Prawe kliknięcie na pusty obszar i wybierz Add Component ze skróconego Menu.
  2. Utwórz nowy komponent typu Stationary, o nazwie S1.
  3. Skonfiguruj ustawienia:

    SettingValue
    Mesh > FileStator.gtm
  4. Utwórz nowy komponent typu Rotating, o nazwie R1.
  5. Skonfiguruj ustawienia:

    SettingValue
    Component Type > Value523.6 [radian s^-1]
    Mesh > Filerotor.grd
    Options > Mesh Unitsm

    Uwaga!

    Komponenty muszą być wprowadzone jak wyżej (najpierw kierownice, następnie wirnik), aby poprawnie zostały utworzone interfejsy. Kolejność komponentów może być zmieniona poprzez prawe kliknięcia na S1 i wybranie Move Component Up.

    Kiedy komponent jest zdefiniowany, Turbo Mode automatycznie wybierze listę obszarów, które odpowiadają niektórym typom brzegowym. Ta informacja powinna zostać sprawdzona w sekcji Region Information, aby upewnić się, że wszystko zrobione jest poprawnie. Ta informacja pomoże ustawić warunki brzegowe i interfejsy. Powyższe turbo regions, które są wybrane (np. piasta) odpowiadają nazwie regionów w CFX-TASCflow grd pliku. Siatki obliczeniowe maszyn przepływowych w CFX-TASCflow używają tych nazw konsekwentnie.

     

  6. Kliknij Passages and Alignment>Edit.
  7. Ustaw Passages and Alignment>Passages/Mesh>Passages per Mesh na 2.
  8. Upewnij się, że Passages and Alignment>Passages to Model jest ustawione na 2.
  9. Kliknij Passages and Alignment>Done.
  10. Kliknij Next.

5.1.3. Definicje wartości fizycznych

W tej sekcji, ustawisz właściwości domen dla płynu i parametry Solver’a.

  1. W panelu Physics Definition ustaw warunki:

    Setting

    Value

    Fluid

    Fluid Air Ideal Gas

    Model Data > Reference Pressure

     0.25 [atm]

    Model Data > Heat Transfer

    Heat Transfer Total Energy

    Model Data > Turbulence

    Turbulence k-Epsilon

    Inflow/Outflow Boundary Templates > P-Total Inlet Mass Flow Outlet

    (Selected)         

    Inflow/Outflow Boundary Templates > Inflow > P-Total

    0 [atm]

    Inflow/Outflow Boundary Templates > Inflow > T-Total

    340 [K]

    Inflow/Outflow Boundary Templates > Inflow > Flow Direction

    Normal to

    Boundary

    Inflow/Outflow Boundary Templates > Outflow > Mass

    Per Component    

    Inflow/Outflow Boundary Templates > Outflow > Mass

    0.06 [kg s^-1]

    Interface > Default Type

    Frozen Rotor

    Solver Parameters

    (Selected)

    Solver Parameters > Advection Scheme

    High Resolution

    Solver Parameters > Convergence Control

    Physical Timescale

    Solver Parameters > Physical Timescale

    0.002 [s]Solver Parameters > Physical Timescale a

     

     

  2. Kliknij Next.

5.1.4. Definicja interfejsu

CFX-Pre będzie starał się utworzyć odpowiednie interfejsy używając nazw obszarów przedstawionych poprzednio w Region Information. W tym wypadku, powinieneś zauważyć, że okresowy interfejs został wygenerowany dla obu wieńców, wirnika i kierownic. Jest to wymagane, gdy modelujemy małą część prawdziwej geometrii stopnia. Interfejs jest również potrzebny, aby połączyć ze sobą dwa komponenty poprzez zmianę ramy .

  1. Przejrzyj różne interfejsy, ale ich nie zmieniaj.
  2. Kliknij Next.

5.1.5. Definicja brzegów (granic) obszaru

CFX-Pre będzie starał się utworzyć odpowiednie warunki brzegowe używając nazw regionów prezentowanych poprzednio w Region Information. W tym wypadku, powinieneś zobaczyć listę utworzonych warunków brzegowych. Mogą być one edytowane lub skasowane w ten sam sposób jak połączenia interfejsów, które były ustawiane wcześniej.

  1. Przeglądnij różne warunki brzegowe, ale ich nie zmieniaj.
  2. Kliknij Next.

5.1.6. Operacje końcowe 

  1. Ustaw Operation na Enter General Mode.
  2. Kliknij Finish.

    Po kliknięciu Finish, pojawi się okienko, z informacją, że Turbo raport nie zostanie uwzględniony w pliku Solver’a,  ponieważ wchodzimy w tryb ogólny.

  3. Kliknij Yes, aby kontynuować.

5.1.7. Pisanie pliku CFX-Solver Input (def.)

  1. Kliknij Define Run.
  2. Skonfiguruj ustawienia:

    Setting

    Value

    File name

    Axiallni.def

  3. Kliknij Save.

    CFX-Solver Manager włączy się automatycznie, i w okienku Define Run, jest już ustawione Solver Input File.

  4. Jeśli używasz trybu stand-alone, zamknij CFX-Pre, zapisując symulację (.cfx) według własnego uznania.

5.2. Uzyskanie rozwiązania używając CFX-Solver Manager

Porównując z poprzednimi tutorialami, siatka dla tego tutorialu zawiera dużo więcej węzłów (jednak jest ona dalej zbyt prosta, by stworzyć symulację CFD wysokiej jakości). Powoduje to zwiększenie czasu rozwiązania problemu. Zaleca się, jeśli jest to możliwe, rozwiązanie tego problemu równolegle. Aby uruchomić ten tutorial, twój komputer powinien mieć minimum 256 MB wolnej pamięci.

Więcej szczegółowych informacji o utworzeniu modelu CFX, tak aby działał równolegle, zobacz w: Flow Around a Blunt Body.

Możesz rozwiązać ten przykład używając Serial, Local, Parallel lub Distributed Parallel.

• Obtaining a Solution in Serial (p. 254)

• Obtaining a Solution With Local Parallel (p. 255)

• Obtaining a Solution with Distributed Parallel (p. 255)

5.2.1. Uzyskanie rozwiązań seryjnych( w Serial)

Jeśli nie masz licencji, na to by uruchomić CFX równolegle, możesz uruchomić go w trybie Serial, klikając Start Run, kiedy otworzy się CFX-Solver Manager. Z procesorem 1GH rozwiązanie trwa około 45 minut.

  1. Kliknij Start Run w okienku Define Run.
  2. Wybierz Post-Process Results.
  3. Jeśli używasz trybu stand-alone, wybierz Shut down CX-Solver Manager.
  4. Kliknij OK.

    Kiedy skończysz przejdź do Viewing the Results Using CFD-Post.

5.2.2. Uzyskanie rozwiązania lokalnego równoległego

Aby uruchomić obliczenia w trybie lokalnie równoległym twój komputer, na którym pracujesz musi mieć więcej niż jeden procesor.

  1. Ustaw Run Mode na paralel mode odpowiednio dla twojego środowiska, np. Platform MPI Local Parallel.
  2. Jeśli jest to wymagane, kliknij Add Partition + aby dodać więcej partycji

    (Domyślnie, przypisane są tu dwie partycje).

  3. Kliknij Start Run.
  4. Zaznacz pole wyboru obok Post-Process Results, wówczas gdy pojawi się  komunikat o zakończeniu obliczeń.
  5. Jeśli używasz trybu stand-alone, zaznacz pole wyboru obok Shut down CFX-Solver Manager.
  6. Kliknij OK.

    Kiedy skończysz, przejdź do Viewing the Results Using CFD-Post.

5.2.3. Uzyskanie rozwiązania z Distributed paralel

  1. Ustaw Run Mode na odpowiedni dla środowiska, w którym pracujesz tryb równoległy, np. Platform MPI Distributed Parallel.

    Jedna partycja powinna zostać wybrana dla użytkownika, na którym jesteś zalogowany.

  2. Kliknij Insert Host, aby określić nowe użytkownika w trybie równoległym.
  3. W Select Parallel Host, wybierz inną nazwę użytkownika ( powinien to być komputer, na którym możesz się zalogować używając taką samą jak dotąd nazwę użytkownika).
  4. Kliknij Add, następnie Close.
  5. Kliknij Start Run.
  6. Zaznacz okno wyboru obok Post-Process Results, kiedy już pojawi się  komunikat o zakończeniu obliczeń.
  7. Jeśli używasz trybu stand-alone, zaznacz okno wyboru obok Shut down CFX-Solver Manager,
  8. Kliknij OK.


5.3. Przeglądanie wyników używając CFD-Post

Funkcja Turbo-Post będzie przestawiona w następującej sekcji. Funkcja ta jest stworzona po to, by zredukować wysiłek potrzebny dla post procesowych symulacji maszyn przepływowych. Aby zobaczyć szczegóły, patrz: Turbo Workspace.

5.3.1. Inicjowanie Turbo Post

Kiedy wprowadzamy turbo komponenty, zakres, a (osiowy), r (promieniowy) i theta, współrzędne są generowane dla każdego komponentu. Ponadto, po wejściu do przestrzeni roboczej Turbo oraz zainicjowaniu turbo komponentów, będziesz gotowy do używania jej specyficznych funkcji turbo, oferowanych w tej przestrzeni roboczej. Funkcje te zawierają: Turbo Tree View, Turbo Surface, Turbo Line i Turbo Plots. Aby poznać szczegóły, zobacz: Turbo Workspace.

By zainicjować Turbo-Post, muszą być ustawione właściwości każdego elementu. Zawierają one dane o wlocie, wylocie, piaście, obudowie, łopatkach, i okresowych regionach. Zawiera również informacje o ilości przypadków każdego tubo elementu, który musi reprezentować pełną geometrię wokół osi obrotu oraz ilość przejść łopatki przez siatkę dla każdego turbo komponentu.

  1. Gdy włączy się CFD-Post, pojawi się okienko Domain Selector. Jeśli się ono pojawi, upewnij się, że obie domeny R1 i S1 są wybrane, następnie kliknij OK, aby załadować wyniki z tych domen.
  2. Kliknij przycisk Turbo.

    Pojawia się okienko Turbo Initialization i program pyta się, czy chcemy auto inicjalizować wszystkie komponenty.

    UWAGA:

    Jeśli okno Turbo Initialization nie pojawia się, to aby zainicjować wszystkie elementy, alternatywą jest kliknięcie przycisku Initialize All Components, który jest widoczny domyślnie lub po dwukrotnym kliknięciu Initialization object w drzewie poleceń Turbo.

  3. Kliknij YES.

    W tym wypadku, inicjalizacja działa bez problemów. Jeśli jednak wystąpił problem inicjalizacji elementu, informacja o tym pojawi się w drzewie poleceń.

5.3.2. Przeglądanie 3 domen przejścia (kanałów?)

Następnie należy utworzyć transformację, aby wykreślić 3 przejścia  łopatek dla kierownicy i 6 przejść łopatek dla wirnika. Zostało to wybrane w celu utworzenia trzykrotną geometrię, która została użyta w symulacji, aby zwizualizować zmiany ciśnienia. Widząc sąsiednie przejścia, da to lepsze zrozumienie zmian ciśnienia na stopniu turbiny. Właściwości każdej domeny zostały już wprowadzone w Initialization. Następne kroki, będą polegać na utworzeniu grupy powierzchni, aby pokolorować powierzchnię łopatki i piastę z tą samą zmienną.

  1. Z głównego menu, wybierz Insert>Location>Surface Group.
  2. Kliknij OK.
  3. Skonfiguruj ustawienia następująco:

    Tab

    Setting

    Value

    Geometry

    Locations

    R1 Blade, R1 Hub, S1 Blade, S1 Hub

    Color

    Mode

    Variable

    Variable

    Pressure

  4. Kliknij Apply.
  5. Kliknij przycisk Turbo.
  6. Otwórz Plots>3D View, aby móc edytować.
  7. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    3D View

    Instancing>Domain

    R1

    Instancing>#of Copies

    3

  8. Kliknij Apply.
  9. Skonfiguruj następujące ustawienia:

    Tab

    Setting

    Value

    3D View

    Instancing>Domain

    S1

    Instancing>#of Copies

    3

  10. Kliknij Apply.
  11. Kliknij przycisk Outline, aby zobaczyć grupę powierzchni.

5.3.3. Wykres Turbo obciążenia łopatek

W tej sekcji, utworzysz wykres ciśnienia wokół łopatek kierownic dla danego położenia wzdłuż obwodu profilu.

  1. Kliknij przycisk Turbo.
  2. W drzewie Turbo, podwójnie kliknij Blade Loading.

Ten profil przebiegu krzywej ciśnienia jest typowy dla zastosowań maszyn przepływowych.

Kiedy zakończysz oglądanie wykresu, zamknij CFD-Post.

6 Symulacja stopnia turbiny z chwilowymi wartościami dla modelu wirnika z kierownicami

Będziesz teraz tworzył symulację wartości chwilowych  dla modelu wirnika z kierownicami. Istniejąca symulacja stanu ustalonego z nieruchomym wirnikiem jest modyfikowana po to, aby zdefiniować symulację dla wartości chwilowych wirnika z kierownicami. Jeśli nie ukończyłeś symulacji z nieruchomym wirnikiem, przed przystąpieniem do symulacji z wartościami chwilowymi,  odnieś się do Simulation the Stage with the Frozen Rotor Model (p.251).

6.1. Zdefiniowanie problemu używając CFX-Pre

W tej sekcji opisano krok po kroku przepływy fizyczne w CFX-Pre.

Jeśli chcesz utworzyć symluację automatycznie i kontynuować w Obtaining the Solution Using CFX-Solver Manager (p.261), włącz Axial.pre.

UWAGA

Plik utworzy nową symulację nazwaną Axial.cfx, lecz nie zmodyfikuje istniejącej bazy danych. Skopiuje on również wymagane pliki wartości wejściowych z przykładowego katalogu do obecnie używanego.

Ten krok wymaga otworzenia oryginalnej symulacji i zapisanie jej w innym miejscu.

  1. Jeśli CFX-Pre nie jest włączony, zrób to.
  2. Otwórz plik z wynikami AxialIni_01.res.
  3. Zapisz je jako Axial.cfx w katalogu, w którym pracujesz.

6.1.1. Modyfikacja fizycznych definicji

By zdefiniować symulację chwilową musisz zmodyfikować domenę. Będziesz ją włączał na okres czasu, tak aby łopatki przeszły przez 1 nachylenie (6.3720) używając 10 kroków czasowych. Jest to za mało kroków, aby uzyskać wyniki wysokiej jakości, lecz wystarczające na potrzeby tutorialu. Krok czasowy jest wyliczany następująco:

UWAGI             

Prędkość obrotowa = 523,6 rad/s

Zamodelowane nachylenie wirnika =2*(2π rad/113)=0,1112rad

Czas aby przejść przez 1 nachylenie = 90,1112 rad)/(523,6 rad/s)=2,124e-4s

Odkąd jest używane 10 kroków czasowych, po tym interwale każdy krok czasowy powinien wynosić 2,124e-5s.

  1. Wybierz Tools>Turbo Mode.

    Wyświetlane są wówczas Basic Settings.

  2. Skonfiguruj następujące ustawienia:

    Setting

    value

    Analysis Type>Type

    Transient

    Analysis Type>Total Time

    2,124e-4[s]a

    Analysis Type>Time Steps

    2,124e-5[s]b

     a- daje to 10 kroków czasowych po 2,124e-5s

     b-ten krok czasowy będzie wykorzystywany, dopóki nie będzie osiągnięty całkowity czas.

     

  3. Kliknij Next.

    Wyświetlany jest Component Definition.

  4. Kliknij Next.

    Wyświetlany jest  komunikat Physics Definition.

  5. Skonfiguruj następujące ustawienia:

    Ustawienia

    Wartość

    Fluid

    Air Ideal Gas

    Interface>Default Type

    Transient Rotor Stator

    UWAGA

    Obliczenia dla wartości chwilowych często przechodzą więcej niż przez 1 nachylenie. W tych przypadkach może to być przydatne do tego, by zobaczyć różne wyniki uśrednione w przedziale czasu wymaganego do ukończenia 1 nachylenia. Możesz porównać wyniki dla każdego obrotu nachylenia, aby zobaczyć czy stan ustalony został osiągnięty, czy też przepływ nadal się rozwija.

     

  6. Kliknij Next.

    Wyświetla się ostrzeżenie.

  7. Kliknij Yes.

    Wyświetlany jest komunikat Interface Definition.

  8. Kliknij Next.

    Wyświetla się Boundary Definition.

  9. Kliknij Next.

    Final Operations jest wyświetlone.

  10. Upewnij się, że polecenie Operation jest ustawione na Enter General mode.
  11. Kliknij Finish.

    Pojawi się komunikat, że raport turbo nie będzie uwzględniany w pliku solver.

  12. Aby kontynuować kliknij Yes.

    Wymagane są wartości wejściowe, ale będą one dostarczone później, używając plików wyników.

6.1.2. Ustawianie wyjściowej kontroli

1. Kliknij Output control.

2. Kliknij przycisk Trn Results.

3. W drzewie Transient Results, kliknij Add new item, ustaw Name w Transient Results 1, i kliknij OK.

4.Skonfiguruj następujące ustawienia:

Option

Selected Variables

Output Variables Lista

Pressure, Velocity, Velocity in Stn Frame

Output Frequency>Option

Time Interval

Output Frequency>Time Interval

2,124e-5[s]

a-użyj CTRL aby wybrać więcej niż jedną zmienną

5. Kliknij OK.

6.1.3. Modyfikacja kontroli wykonawczej

  1. Kliknij Execution Control.
  2. Skofiguruj następujące ustawienia: 

    Tab

    Setting

    Value

    Run Definition

    Solver Input File

    Axial.defa

    a-nie potrzeba ustawić ścieżki, chyba, że planujesz zapisać plik solver gdzie indziej niż w katalogu roboczym.

     

  3. Kliknij Execution Control.
  4. Skofiguruj następujące ustawienia: 

6.1.4. Zapisywanie pliku CFX-Solver Input(.def)

  1. Kliknij Define Run.

    Pojawi się ostrzeżenie, spowodowane niedoborem wartości wejściowych.

    Wartości wejściowe są tu wymagane, lecz będą uzupełnione później, używając plików wyników.

  2. Kliknij Yes.
  3. Jeśli używasz trybu stand-alone, zamknij CFX-Pre, zapisz symulację (.cfx) według własnego uznania.

6.2. Uzyskanie rozwiązania używając CFX-Solver Manager

Kiedy włączy się CFX-Solver Manager, będziesz musiał określić wartości wejściowe przed włączeniem CFX-Solver.

6.2.1. Rozwiązanie seryjne

  1. Wybierz Run Definition>Initial Values Specification.
  2. Pod Initial Values Specification>Initial Values wybierz Initial Values 1.
  3. Pod Initial Values Specification>Initial Values> Initial Values 1 Settings>File name, kliknij Browse.
  4. Wybierz AxialIni_001.res z katalogu roboczego.
  5. Kliknij Open.
  6. Pod Initial Values Specification>Use Mesh From, wybierz Solver Input File.
  7. Kliknij Start Run.

    CFX-Solver już działa w celu otrzymania rozwiązania. Na końcu pojawi się okienko informujące o zakończeniu symulacji.

  8. Wybierz Post-Process Results.
  9. Jeśli używasz trybu stand-alone, wybierz Shut down CFX-Solver Manager.
  10. Kliknij OK. Kontynuuj ten tutorial z Monitoring the Run (p.261).

6.2.2. Rozwiązania równoległe

Naśladuj pierwsze 6 kroków z procedury seryjnej przedstawionej powyżej (Serial Solution (p.261)),  następnie wykonaj procedurę lokalną równoległą lub rozpowszechnionej równoległej z 1 części tego tutorialu (Obtaining theSolution Using CFX-Solver Manager(p.254)).

6.2.3. Monitorowanie przebiegu

Podczas rozwiązania, zobacz dodatkowe informacje, które są zapewnione dla przebiegów chwilowych w układzie wirnik-kierownice. Za każdym razem wirnik obraca się do następnej pozycji, liczba stopni obrotu i ułamek nachylenia jest podawany. Po 10 krokach czasowych powinieneś zobaczyć, że wirnik przeszedł przez 1 nachylenie.

6.3. Obserwowanie wyników używając CFD-Post

Aby sprawdzić chwilowe interakcje pomiędzy wirnikiem i kierownicami musisz utworzyć animację ciśnienia łopatka do łopatki. Jako podstawa dla tego wykresu będzie używana powierzchnia turbo.

6.3.1. Inicjalizowanie Turbo-Post

Podczas inicjalizacji turbo komponentów będzie wykonany cały pre-processing. Tylko kilka kroków będzie wymaganych do tego, by wyświetlić powierzchnię ciągłego okresu oraz stworzyć powierzchnię turbo omawianą później w tym tutorialu.

  1. Kliknij przycisk Turbo.

    Wyświetlane jest okienko Turbo Initialization i pyta czy chcemy auto inicjalizować wszystkie komponenty.

    UWAGA

    Jeśli nie widzisz okienka Turbo Initialization, alternatywnie możesz inicjalizować wszystkie komponenty klikając przycisk Initialize All Components, który jest widoczny domyślnie lub poprzez podwójne kliknięcie Initialization w drzewie Turbo.

  2. Kliknij Yes.

    Oba komponenty (domeny) są zainicjalizowane bazując na automatycznym wyborze turbo regionów. Kiedy proces jest kompletny, obok każdego komponentu na liście pojawi się ikona zielonej turbiny. Można również wyświetlić zielone tło mesha dla każdego zainicjalizowanego komponentu.

  3. Wykonaj podwójne kliknięcie Component 1 (S1) i przeglądnij automatycznie wybrane turbo regiony i inne dane w widoku szczegółowym.
  4. Wykonaj podwójne kliknięcie Component 2 (R1) i przeglądnij automatycznie wybrane turbo regiony oraz inne dane w widoku szczegółowym (zawierające Passages per Component, ustawiając przycisk Instancing, który powinien mieć wartość 2).

6.3.2. Wyświetlanie powierzchni ciągłego okresu

W drzewie Turbo, podwójnie kliknij na Blade-to-Blade.

Pojawi się powierzchnia ciągłego okresu, pokolorowana zmianami ciśnienia. Obiekt ten może być edytowany oraz ponownie wyświetlany przy użyciu widoku szczegółowego.

6.3.3. Używanie raportów przeglądania Multiple Turbo

  1. W drzewie Turbo wykonaj podwójne kliknięcie na Initialization.
  2. Kliknij Three Views.

    Lewy widok to 3D View, górny prawy to Blade to Blade i dolny prawy to widok Meridional.

  3. Kliknij Single View.

6.3.4. Tworzenie pośredniego okresu na powierzchni turbo

1. Utwórz Turbo Surface wybierając Insert>Location>Turbo Surface z dolnego menu z wartością Constant Span ustawioną na 0,5.

2.Pod przyciskiem Color wybierz Variable i ustaw na Pressure z wartościami wybieranymi przez użytkownika z zakresu pomiędzy 10000 [Pa] a 7000 [Pa].

6.3.5. Ustawienie przykładowych transformacji

Następnie, aby zobaczyć szerszą sekcję modelu, będziesz używał przykładowych transformacji. Ustawienia każdej domeny były już wybrane podczas fazy inicjalizacji, więc teraz należy ustalić tylko ilość przypadków.

  1. W drzewie Turbo, wykonaj podwójne kliknięcie na 3DView.
  2. W sekcji Instancing, ustaw #of Copies na 6 dla R1.
  3. Kliknij Apply.
  4. W sekcji Instancing, ustaw #ofCopies na 6 dla S1.
  5. Kliknij Apply.
  6. Powróć do konspektu i upewnij się, że powierzchnia turbo jest ponownie widoczna.

6.3.6. Animacja ruchu wirnika względem kierownic

Zacznij ładując pierwszy krok czasowy:

  1. Kliknij Timestep Selector.
  2. Wybierz wartość czasu równą 0.
  3. Kliknij Apply, by załadować krok czasowy. Łopatki wirnika poruszają się do pozycji startowej. Jest to dokładnie 1 nachylenie względem poprzedniej pozycji więc łopatki się nie poruszą.
  4. Wyłącz widoczność Wireframe.
  5. Wypozycjonuj geometrię jak to pokazano poniżej, gotową na animację. Podczas animacji łopatki wirnika będą poruszać się w prawo. Upewnij się, że nie masz co najmniej dwóch łopatek wirnika w widoku po lewej stronie. Pojawią się podczas animacji.
  6. W pasku na górze okna kliknij Animation.
  7. W okienku Animation, wybierz opcję Keyframe Animation.
  8. Kliknij New, aby utworzyć KeyframeNo1.
  9. Wybierz KeyframeNo1, potem ustaw #ofFrames na 9, a następnie naciśnij Enter w okienku #ofFrames.

    Zalecienie

    Upewnij się, zanim będziesz kontynuował, aby wcisnąć Enter i potwierdzić, że nowa liczba pojawiła się w liście.

  10. Użyj Timestep Selector, by załadować końcowy krok czasowy.
  11. W okienku Animation, kliknij New, aby utworzyć KeyframeNo2.
  12. Kliknij More Animation options, aby rozszerzyć okienko Animation.
  13. Kliknij Options i ustaw Transient Case na TimeValue Interpolation. Kliknij następnie OK.

    Animacja zawiera teraz 11 ramek (9 pośrednich plus dwie Keyframes), jedna dla każdej dostępnej wartości czasowej.

  14. W powiększonym okienku Animation, wybierz Save Movie.
  15. Ustaw Format na MPEG1.
  16. Kliknij Browse, obok okienka Save Movie i ustaw nazwę pliku na odpowiednią.
  17. Jeśli ramka 1 nie jest załadowana (pokazane w F: okienko tekstowe na dole okienka Animation), aby je załadować kliknij To Beginning.
  18. Kliknij Play the animation.

 

- Zajmuje to chwilę czasu, by animacja została ukończona

- Aby zobaczyć film będziesz potrzebował odtwarzacza, który odtwarza format MPEG.

Na podstawie animacji oraz z wykresów utworzonych wcześniej będziesz w stanie zobaczyć, że przepływ nie jest ciągły wzdłuż interfejsu. Jest to spowodowane zmianą nachylenia. Odnosi się do tego również stosunkowo gruba siatka i mała liczba kroków czasowych użyta w symulacji dla wartości chwilowych. Film został utworzony z wąskim zakresem ciśnienia porównanym do globalnego zakresu, który wyolbrzymia różnicę w poprzek interfejsu.

6.3.7. Dalszy Post-processing

Możesz stworzyć raport dla turbiny w sposób następujący:

  1. Kliknij File>Report>Report Templates.
  2. W okienku Report Templates, wybierz Turbine Report, następnie kliknij Load.

    Raport wygeneruje się wówczas automatycznie.

  3. Kliknij przycisk Report Viewer(zlokalizowany poniżej okna podglądu).

    Pojawi się pełny raport.

    Należy zauważyć, że poprawny raport zależy od właściwej turbo inicjalizacji.






 


















  • No labels