Page tree
Skip to end of metadata
Go to start of metadata

1. Funkcje poradnika

W tym poradniku nauczysz się o:

  • Ustawianiu domeny immersed solids (ciała stałe zanurzone w płynie).
  • Zastosowaniu warunku brzegowego ściany obracającej się w przeciwnym kierunku ( counter-ratating wall boundary)
  • Monitorowaniu formuł w czasie pracy solvera
  • Tworzeniu chwilowego wykresu XY w CFD-Post
  • Tworzeniu kluczowej animacji klatkowej (keyframe animation)

Component

Feature

Details

CFX-Pre

User Mode

General Mode

Domain Type

Immersed Solid

Fluid Domain

Analysis Type

Transient

Fluid Type

Continuous Type

Boundary Conditions

Inlet Boundary

Outlet Boundary

Domain Interface

Fluid Fluid

CFD-Post

Chart

Mass Flow Rate

Animation

Keyframe

2. Zdefiniowanie problemu do rozwiązania

W tym poradniku zasymulujesz pompę zębatą wymuszającą przepływ wody. Poradnik wykorzystuje funkcję ANSYS CFX - Immersed Solids , aby móc zamodelować bryłę, która przemieszcza się w płynie.

 

Na wylocie z pompy średnie ciśnienie statyczne w ruchu względnym wynosi 1 psi (6.9 kPa); ciśnienie całkowite (spiętrzenia) na wlocie wynosi 0 psi (względem otoczenia). Wirnik wewnętrzny (zębatka) obraca się z prędkością obrotową 7 obr/s; wirnik zewnętrzny obraca się z prędkością obrotową 6 obr/s. Średnica obszaru płynu znajdującego się pomiędzy wirnikami wynosi około 7,3 cm.

Użyjesz domeny immersed solid, by zamodelować wirnik wewnętrzny, a do zamodelowania płynu (wody) bezpośrednio otaczającego wirnik wewnętrzny użyjesz wirującej domeny płynu, ponadto, aby zamodelować wodę w kanałach wlotowych i wylotowych użyjesz stacjonarnej domeny płynu. Aby zamodelować stacjonarną obudowę pompy (nie pokazana na rysunku), zastosujesz warunek ściany przeciwnie obracającej się względem górnej powierzchni (duże wartości Z) dla wirującej domeny płynu, na niepokrywającej się powierzchni (leży ona pomiędzy kanałem wlotowym i wylotowym). W celu zamodelowania górnych powierzchni zębów wirnika zewnętrznego, zastosujesz warunek ściany wirującej na odcinkach niepokrywających się na dolnych powierzchniach (małe Z) komór wlotowej i wylotowej. Więcej o warunkach nie zachodzenia (non-overlaping) możesz dowiedzieć się z rozdziału: „ Non-overlap Boundary Conditions in the CFX-Solver Modeling Guide”.

Następujące warunki muszą być spełnione, aby wspomagać tworzenia cyklicznych modeli przepływu:

  • Siatka domeny wirującej powinna być obrotowo okresowa, co oznacza, że musi wyglądać tak samo po każdym przejściu zęba wirnika (zewnętrznego).
  • Siatka na zewnętrznej granicy domeny immersed solid powinna być obrotowo okresowa, co oznacza, że musi wyglądać tak samo po każdym przejściu zęba wirnika wewnętrznego. (Siatka wewnątrz domeny immersed solid nie ma żadnego wpływu, w tym poradniku)
  • Przejściu jednego zęba wirnika powinna odpowiadać całkowita liczba kroków czasowych.

3. Zanim zaczniesz

Zaleca się, abyś przed rozpoczęciem tego rozdziału poznał poprzednie rozdziały tego poradnika. Jeżeli jest to Twój pierwszy poradnik, który przerabiasz, ważne jest, aby przed jego rozpoczęciem przejrzeć poniższe treści:

  • Ustawienie katalogu roboczego i uruchomienie ANSYS CFX w trybie samodzielnym (Stand-alone).
  • Uruchomienie poradników ANSYS CFX używając ANSYS Workbench.
  • Zmiana kolorów wyświetlania (Display colors).
  • Odtworzenie pliku sesji tutoriala tego poradnika (Tutorial session flie).

4. Określanie ustawień projektu

  1. Przygotuj katalog roboczy używając poniższych plików w katalogu: examples.

5. Definiowanie problemu w CFX-Pre

Jeżeli chcesz automatycznie zdefiniować problem używając pliku sesji tutoriala poradnika, otwórz ImmersedSolid.pre. Aby uzyskać więcej informacji zobacz rozdział: Playing a Tutorial Session File. Następnie przystąp do rozdziału: Obtaining the Solution Using CFX-Solver Manager.

Jeżeli chcesz zdefiniować problem ręcznie, przystąp do poniższych kroków:

Ta sekcja opisuje krok po kroku definiowanie fizyki przepływu w CFX-Pre dla symulacji stanów ustalonych (steady- state simulation).

  1. W CFX-Pre naciśnij File > New Case.
  2. Wybierz General i kliknij OK.
  3. Naciśnij File > Save Case As.
  4. Pod File name, wpisz ImmersedSolid.cfx.
  5. Kliknij Save.

5.1. Importowanie siatki

  1. Edytuj Case Options > General w szkicu drzewa projektu (Outline) i upewnij się, że jest wyłączona opcja Automatic Default Domain (automatyczna domyślna domena).
    Domyślne generowanie domeny powinno być wyłączone, ponieważ później stworzysz ręcznie trzy domeny.
  2. Kliknij OK.
  3. Kliknij prawym przyciskiem myszy Mesh i wybierz Import Mesh > CFX Mesh.
    Okno dialogowe Import Mesh otwiera się.
  4. Skonfiguruj poniższe ustawienia:

Setting

Value

File name

ImmersedSolid.gtm

Kliknij OPEN

5.2. Tworzenie równań dla kroku czasowego i całkowitego czasu

W kolejnym kroku utworzysz wyrażenie określające wartość kroku czasowego dla tej analizy przejściowej (transient). Jeden ząb wewnętrznego (lub zewnętrznego) wirnika przemieszcza się co 1/42 s. Wybierz krok czasowy, który rozwiąże ten ruch w 30 odstępach.

  1. Z głównego menu wybierz Insert > Expressions, Functions and Variables > Expression.
  2. W oknie dialogowym Insert Expression wpisz dt.
  3. Kliknij OK.
  4. Ustaw Definition na (1/42) [s]/30.
  5. Kliknij Apply, aby stworzyć równanie.

Następnie utworzysz równanie określające całkowity czas symulacji. Stwórz długość symulacji w taki sposób, aby trzy zęby wirnika przechodziły: 3/42 s. Da to czas do rozwiązania, aby ustalić jego okresowy charakter.

  1. Stwórz wyrażenie nazwane total time.
  2. Ustaw Defenition na (3/42) [s].
  3. Kliknij Apply.

5.3. Ustawianie typu analizy (Setting the analysis type)

Zdefiniuj symulację, jako przejściową (transient) używając równania, które wcześniej stworzyłeś.

  1. Pod etykietą szkicu (Outline tab) edytuj Analysis Type .
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    External Solver Coupling > Option

    None

    Analysis Type > Option

    Transient

    Analysis Type > Time Duration > Option

    Total Time

    Analysis Type > Time Duration > Total Time

    total time [a]

    Analysis Type > Time Steps > Option

    Timesteps

    Analysis Type > Time Steps > Timesteps

    dt

    Analysis Type > Initial Time > Option

    Automatic with value

    Analysis Type > Initial Time > Time

    0 [s]

    Przypis

    1. Najpierw musisz kliknąć ikonę Enter Expression obok pola.

     

  3.  Kliknij OK.

5.4. Tworzenie Domen

Ta symulacja wymaga trzech domen: dwóch domen płynu i jednej domeny immersed solid. Na początku stworzysz domenę immersed solid.

5.4.1. Tworzenie domeny Immersed Solid

Upewnij się, że żadna domena domyślna nie istnieje pod Flow Analysis 1. Jeżeli taka domena domyślna istnieje, kliknij prawym przyciskiem na nią i wybierz Delete.

Stwórz domenę immersed solid według następujących punktów:

  1. Wybierz Insert > Domain z głównego menu lub kliknij Domain .
  2. W oknie dialogowym Insert Domain wpisz nazwę ImmersedSolid i kliknij OK.
  3. Skonfiguruj poniższe ustawienia:

Tab

Setting

Value

Basic Settings

Location and Type > Location

Inner Rotor

Location and Type > Domain Type

Immersed Solid

Location and Type > Coordinate Frame

Coord 0

Domain Models > Domain Motion > Option

Rotating

Domain Models > Domain Motion > Angular Velocity

7 [rev s^-1]

Domain Models > Domain Motion > Axis Definition > Option

Two Points

Domain Models > Domain Motion > Axis Definition > Rotation Axis From

0.00383, 0 ,0

Domain Models > Domain Motion > Axis Definition > Rotation Axis To

0.00383, 0 ,1

 Kliknij OK.

5.4.2. Tworzenie stacjonarnej domeny płynu (Stationary fluid domain)

Stwórz stacjonarną domenę płynu według opisu:

  1. Stwórz nową domenę pod nazwą StationaryFluid.
  2. Skonfiguruj poniższe ustawienia:

Tab

Setting

Value

Basic Settings

Location and Type > Location

Channels

Location and Type > Domain Type

Fluid Domain

Location and Type > Coordinate Frame

Coord 0

Fluid and Particle Definitions

Fluid 1

Fluid and Particle Definitions> Fluid 1 > Option

Material Library

Fluid and Particle Definitions > Fluid 1 > Material

Water

Fluid and Particle Definitions > Fluid 1 > Morphology > Option

Continuous Fluid

Domain Models > Pressure > Reference Pressure

0 [psi]

Domain Models > Buoyancy Models > Option

Non Buoyant

Domain Models > Domain Motion > Option

Stationary

Domain Models > Mesh Deformation > Option

None

Fluid Models

Heat Transfer > Option

None

Turbulence > Option

k-Epsilon

Turbulence >Wall Function

Scalable

Combustion > Option

None

Thermal Radiation

None

Initialization

Domain Initialization

(Selected)

 

Domain Initialization > Initial Conditions > Velocity Type

Cartesian

 

Domain Initialization > Initial Conditions > Cartesian Velocity Components > Option

Automatic with Value

 

Domain Initialization > Initial Conditions > Cartesian Velocity Components > U

0 [m s^-1]

 

Domain Initialization > Initial Conditions > Cartesian Velocity Components > V

0 [m s^-1]

 

Domain Initialization > Initial Conditions > Cartesian Velocity Components > W

0 [m s^-1]

 

Domain Initialization > Initial Conditions > Static Pressure > Option

Automatic with Value

 

Domain Initialization > Initial Conditions > Static Pressure > Relative Pressurea

1 [psi]* step(-y/1[cm])

 

Domain Initialization > Initial Conditions> Turbulence > Option

Medium ( Intensity=5%)

 

a ten warunek początkowy poprawia numeryczną stabilność poprzez uniknięcie niekorzystnego gradientu ciśnienia na wylocie.

Kliknij OK.

5.4.3. Tworzenie obrotowej domeny płynu (Rotating fluid domain)

Utwórz obrotową domenę płynu według opisu:

  1. W szkicu drzewa projektu (Outline) kliknij prawym przyciskiem myszy Simulation > Flow Analysis 1 > StationaryFluid i wybierz Duplicate.
  2. Kliknij prawym przyciskiem myszy Simulation > Flow Analysis 1 > Copy of StationaryFluid  i wybierz Rename.
  3. Zmień nazwę domeny na RotatingFluid.
  4. Edytuj domenę RatatingFluid.
  5. Skonfiguruj poniższe ustawienia:

Tab

Setting

Value

Basic Settings

Location and Type > Location

Gear Chamber

Domain Models > Domain Motion > Option

Rotating

Domain Models > Domain Motion> Angular Velocity

6 [rev s^-1]

Domain Models > Domain Motion > Axis Definition > Option

Coordinate Axis

Domain Models > Domain Motion > Axis Definition > Ratation Axis

Global Z

 Kliknij OK.

5.5. Tworzenie interfejsu domeny (Domain interface)

Dodaj interfejs domeny, który połączy domeny: StationaryFluid  i RotatingFluid.

  1. Kliknij Insert > Domain Interface z menu głównego lub kliknij Domain Interface .
  2. Zaakceptuj domyślną nazwę interfejsu domeny i kliknij OK.
  3. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Interface Type

    Fluid Fluid

    Interface Side 1 > Domain (Filter)

    StationaryFluid

    Interface Side 1 > Region List

    Channel Side

    Interface Side 2 > Domain ( Filter)

    RotatingFluid

    Interface Side 2 > Region List

    Chamber Side

    Interface Models > Option

    General Connection

    Interface Models > Frame Change/Mixing Model > Option

    Transient Rotor

    Stator

    Interface Models > Pitch Change>Option[a]

    None

    Additional Interface Models

    Mass and Momentum > Option

    Conservative Interface Flux

    Mass and Momentum > Interface Model > Option

    None

    Mesh Connetion

    Mesh Connetion Method > Mesh Connection > Option

    GGI

     

    Przypis

    1. Ustawienie tej opcji na None wygeneruje globalne ostrzeżenie w oknie komunikatów poniżej przeglądarki. W tym wypadku ostrzeżenie może zostać zignorowane, ponieważ zostało zamodelowane pełne 360o po dwóch stronach interfejsu.
  4. Kliknij OK.

Zastosuj warunek ściana obracająca się przeciwnie, bez poślizgu (counter-rotating no-slip wall), do niepokrywających się odcinków interfejsu domeny na wirującej stronie domeny, ponieważ ta powierzchnia reprezentuje część stacjonarnej obudowy pompy.

  1. Edytuj RotatingFluid > Domain Interface 1 side 2.

    Jeżeli obiekt nie pojawia się w drzewie projektu, to edytuj Case Options > General i wybierz Show Interface Boundaries in Outline Tree, następnie kliknij OK.

  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Nonoverlap Conditions

    Nonoverlap Conditions

    (Selected)

    Nonoverlap Conditions > Mass and Momentum> Option

    No Slip Wall

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity

    (Selected)

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity > Option

    Counter Rotating Wall

  3. Kliknij OK.

Zastosuj warunek ściany wirującej bez poślizgu dla niepokrywających się części interfejsu po stronie domeny stacjonarnej, ponieważ te powierzchnie reprezentują ściany na zębie wirnika zewnętrznego, a drugi ząb obraca się z prędkością 6 obr/s wokół osi Z.

  1. Edytuj StationaryFluid>Domain Interface 1 Side 1
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Nonoverlap Conditions

    Nonoverlap Conditions

    (Selected)

    Nonoverlap Conditions > Mass and Momentum > Option

    No Slip Wall

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity

    (Selected)

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity > Option

    Rotating Wall

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity > Angular Velocity

    6 [rev s^-1]

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity > Axis Definition > Option

    Coordinate Axis

    Nonoverlap Conditions > Mass and Momentum > Wall Velocity > Axis Definition > Rotation Axis

    Global Z

  3. Kliknij OK.

5.6. Tworzenie warunków brzegowych (Boundary conditions)

Ta sekcja nakreśla kroki potrzebne do utworzenia warunków brzegowych na wlocie i wylocie określonych w opisie problemu.

5.6.1. Warunek brzegowy na wlocie (Inlet Bondary)

Utwórz wlotowe ciśnienie całkowite o wartości 0 psi (0 kPa) względem otoczenia:

  1. W szkicu drzewa projektu (Outline) kliknij prawym przyciskiem myszy StationaryFluid oraz wybierz Insert > Boundary.
  2. Wpisz nazwę w pole Name na in i kliknij OK.
  3. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Boundary Type

    Inlet

    Location

    Inlet

    Boundary Details

    Mass And Momentum > Option

    Total Pressure ( stable)

    Mass And Momentum > Relative Pressure

    0 [psi]

    Flow Direction > Option

    Normal to Boundary Condition

    Turbulence > Option

    Medium (Intensity=5%)

    Kliknij OK.

5.6.2. Wylotowy warunek brzegowy (Outlet boundary)

Utwórz na wylocie średnie ciśnienie statyczne 1 psi (6.9 kPa) względem otoczenia:

  1. Stwórz warunek brzegowy o nazwie out w domenie StationaryFluid.
  2. Skonfiguruj poniższe ustawienia:

Tab

Setting

Value

Basic Settings

Boundary Type

Outlet

 

Location

Outlet

Boundary Details

Mass And Momentum > Option

Average Static Pressure

 

Mass And Momentum > Relative Pressure

1 [psi]

 

Mass And Momentum > Pres. Profile Blend

0,05

 

Pressure Averaging > Option

Average Over Whole Outlet

5.7. Ustawienie kontroli solvera (Solver Control)

  1. Kliknij Solver Control .
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Basic Settings

    Advection Scheme > Option

    High Resolution

    Transient Scheme > Option

    Second Order Backward Euler

    Transient Scheme > Timestep Initialization > Option

    Automatic

    Turbulence Numerics > Option

    First Order

    Convergence Control > Min. Coeff. Loops

    1

    Convergence Control > Max. Coeff. Loops

    10

    Convergence Control > Fluid Timescale Control > Timescale Control

    Coefficient Loops

    Convergence Criteria > Residual Type

    RMS

    Convergence Criteria > Residual Target

    1.0 E-4

  3. Kliknij OK.

5.8. Ustawienie kontroli wyników (Output Control)

Ustaw solver, aby na wyjściu pokazywał pliki z wynikami chwilowymi (transient results), które zawierają ciśnienie, prędkość, prędkość w układzie nieruchomym, w każdej chwili kroku czasowego:

  1. Kliknij Output Control .
  2. Kliknij etykietę Trn Results.
  3. W polu Transient Results kliknij Add new item, ustaw nazwę Name na Transient Results 1  i kliknij OK.
  4. Skonfiguruj poniższe ustawienia Transient Results 1:

    Setting

    Value

    Option

    Selected Variables

    File Compression

    Default

    Output Variables List

    Pressure, Velocity, Valecity in Stn Frame

    Output Boundary Flows

    (Selected)

    Output Boundary Flows > Boundary Flows

    All

    Output Frequency > Option

    Every Timestep

  5. Kliknij etykietę Monitor.
  6. Wybierz Monitor Objects.
  7. Pod polem: Monitor Points and Expressions:
    1. Kliknij Add new item .
    2. Zaakceptuj domyślną nazwę i kliknij OK.
    3. Ustaw pole Option na Expression.
    4. Ustaw pole Expression Value na massFlow()@in
  8. Kliknij OK.

5.9. Zapis pliku CFX-Solver Input(.def)

  1. Kliknij Define Run.
  2. Skonfiguruj poniższe ustawienia:

    Setting

    Value

    File name

    ImmersedSolid.def

  3. Kliknij Save.

    Uwaga

    Pojawi się komunikat ostrzegawczy w związku z globalnym ostrzeżeniem, które zostało wspomniane wcześniej w rozdziale dotyczącym tworzenia interfejsów domen. Kliknij Yes.

    CFX-Solver Manager uruchamia się automatycznie i w oknie dialogowym Define Run ustawiony zostaje Solver Input File.

  4. Jeżeli używasz trybu stand-alone, zakończ CFX-Pre zapisując symulację (.cfx) według własnego uznania.

6. Uzyskiwanie rozwiązania używając CFX-Solver Manager

Kiedy CFX-Pre został wyłączony, a CFX-Solver Manager jest włączony, uzyskaj rozwiązanie problemu CFD według poniższych instrukcji:

  1. W CFX-Solver Manager upewnij się, że zostało wyświetlone okno dialogowe Define Run.

    Jeżeli CFX-Solver Manager jest uruchomiony z poziomu CFX-Pre, wymagana informacja, potrzebna aby wykonać rozruch solvera, zgłasza się automatycznie w oknie dialogowym Define Run.

  2. Kliknij Start Run.

    Rozpoczyna się rozruch solvera, a postęp wyświetlany jest na podzielonym ekranie.

  3. Kliknij etykietę User Points, (która pojawia się po tym, jak zostanie przeliczony pierwszy krok czasowy) i kontroluj wartość Monitor Point, 1 podczas gdy symulacja postępuje.
  4. Przeskaluj wykres z monitora tak, abyś mógł swobodnie widzieć oscylacje czasowo-okresowe w przepływie masowym, które pojawiają się po początkowej fazie przejściowej.
    1. Kliknij prawym przyciskiem myszy gdziekolwiek na wykresie User Points i wybierz Monitor Properties.
    2. W oknie dialogowym Monitor Properties:User Points, w etykiecie Range Settings wybierz Set manual Scale(Linear).
    3. Ustaw dolne i górne granice odpowiednio na: 0,015 i 0,055.
    4. Kliknij OK.
  5. Wybierz pole wyboru (check box) znajdujące się obok Post-Proccess Results, kiedy komunikat o zakończeniu pojawi się na końcu pracy solvera.
  6. Jeżeli używasz trybu stand-alone, wybierz pole wyboru (check box), obok Shut down CFX-Solver Manager.
  7. Kliknij OK.

Uwaga

Podczas pracy Solver Managera, możesz odnotować na  47 i 48 kroku czasowym ostrzeżenie : ”A wall has been placed at portion(s) of an OUTLET boundary condition… to prevent fluid from flowing into the domain”. („Ścianka umieszczona w części obejmującej warunek brzegowy na wylocie… w celu zapobiegania ruchu płynu do domeny”).  Przepływ masowy na wlocie spada w tym punkcie do najniższego poziomu w całym cyklu, powodując redukcję prędkości na wylocie. Z powodu turbulencji na wylocie, ta redukcja prędkości pozwala małym wirom tworzyć małe, prawie nieistotne zjawisko cofania się strumienia na wylocie (backflow). Rysunek poniżej: Wektory prędkości na wylocie pokazuje wektory prędkości na wylocie, kiedy strumień masowy na wlocie jest najmniejszy (w kroku czasowym 48) i gdy strumień masowy jest największy (88 krok czasowy). Na wykresie możesz zobaczyć, gdzie pojawia się ten mały prąd wsteczny w kroku czasowym 48.

 

7. Podgląd wyników z użyciem CFD-Post

W tej sekcji wygenerujesz wykres pokazujący strumień masowy przepływający przez maszynę, jako funkcję czasu. Przygotujesz również animację maszyny w ruchu, uzupełnioną o wektory prędkości.

7.1. Tworzenie wykresu zależności strumienia masowego od czasu (mass flow versus time)

Podczas pracy solvera, na monitorach podglądu obserwowałeś wykresy, które pokazywały zależność strumienia masy w funkcji kroku czasowego. Teraz stworzysz podobny wykres zależności strumienia masowego od czasu. Tak jak zrobiłeś to na wykresie na monitorze podglądu -  dostosuj zakres osi pionowej, by skupić się na oscylacjach czasowo-okresowych w przepływie masowym, jakie pojawiają się po początkowej fazie niestacjonarnej (transient).

  1. Kiedy CFD-Post otwiera się, może się również pojawić okno dialogowe Domain Selector. Jeżeli się ono pojawi, upewnij się, że zarówno domena: ImmersedSolid, RotatingFluid  jak i StationaryFluid są już wybrane. Następnie kliknij OK, by załadować wyniki z tych domen.
  2. Okno dialogowe zgłosi, że przypadek zawiera domenę immersed solid. Kliknij OK, aby kontynuować.
  3. Stwórz nowy wykres i nazwij go: Mass Flow Rate (wydatek masowy).

    Pojawi się przeglądarka wykresu.

  4. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    General

    Type

    XY-Transient or Sequence

    Title

    Mass Flow Rate at the Inlet over Time

  5. Kliknij etykietę Data Series (seria danych).
  6. Jeżeli lista wyboru Data Series jest pusta, kliknij prawym przyciskiem myszy na nią i wybierz New, lub kliknij New
  7. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Data Series

    Series 1

    (Selected)

    Name

    Inlet Mass Flow

    Data Source > Expression

    (Selected)

    Data Source > Expression

    massFlow()@in[1]

    Y Axis

    Axis Range > Determine ranges automatically

    (Cleared)

    Axis Range > Min

    0.015

    Axis Range > Max

    0.055

    Przypis

    1. Będziesz musiał wpisać to ręcznie, albo kliknąć prawym przyciskiem myszy i wybrać z menu skrótów Functions > CFD-Post>mass Flow()@, a następnie wpisać in.

     

  8. Kliknij Apply.

Masowe natężenie przepływu ustawi się, jako powtarzający się wzorzec o okresie 1/42 s, co jest czasem, jaki zajmuje zębowi wirnika, aby przejść.

7.2. Tworzenie wykresu wektorów prędkości (Velocity vector)

Stwórz płaszczyznę przekroju (slice plane), a następnie wykonaj wykres wektorowy na płaszczyźnie przekroju według poniższych punktów:

 

  1. Kliknij w etykietę 3D Viewer.
  2. Stwórz nową płaszczyznę o nazwie Plane 1.
  3. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Geometry

    Domains

    RotatingFluid

    Definition > Method

    XY Plane

    Definition > Z

    0.003 [m]

  4. Kliknij Apply.
  5. Wyłącz widoczność płaszczyzny Plane 1.
  6. Stwórz nowy wykres wektorowy i nazwij go Vector 1.
  7. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Geometry

    Domains

    All Domains

    Definition > Locations

    Plane 1

    Definition > Sampling

    Rectangular Grid

    Definition > Spacing

    0.03

    Definition > Variable

    Velocity

    Color

    Mode

    Use Plot Variable

    Range

    User Specified

    Min

    0 [m s^-1]

    Max

    0.8 [m s^-1]

    Symbol

    Symbol

    Arrow3D

    Symbol Size

    15

    Normalized Symbols

    (Cleared)

  8. Kliknij Apply.

7.3. Zmiana wyglądu w przygotowaniu animacji

Według poniższych punktów, wykonaj kroku, aby wlot i wylot były widzialne:

  1. Edytuj StationaryFluid > in.
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Render

    Show Faces

    (Cleared)

    Show Mesh Lines

    (Selected)

    Show Mesh Lines > Edge Angle

    105 [degree]

    Show Mesh Lines > Line Width

    2

    Show Mesh Lines > Color Mode

    Default

  3. Kliknij Apply.
  4. Zastosuj te same ustawienia dla StationaryFluid>out.

Według poniższych kroków, zrób, aby kanały wlotowe i wylotowe były widzialne:

  1. Edytuj StationaryFluid > StationaryFluid Default.
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Render

    Show Face

    (Selected)

    Show Faces > Transparency

    0.8

    Show Mesh Lines

    (Cleared)

  3. Kliknij Apply.

Według poniższych kroków, zrób, aby ściany wirującej domeny płynu były widzialne:

  1. Edytuj RotatingFluid>RotatingFluid Default.
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Color

    Mode

    Constant

    Color

    (White)

    Render

    Show Faces

    (Selected)

    Show Faces > Transparency

    0.0

    Show Mesh Lines

    (Cleared)

  3. Kliknij Apply.

Według poniższych kroków, zrób, aby były widzialne ściany domeny immersed solid:

  1. Edytuj ImmersedSolid > ImmersedSolid Default.
  2. Skonfiguruj poniższe ustawienia:

    Tab

    Setting

    Value

    Color

    Mode

    Constant

    Color

    (Blue)

    Render

    Show Faces

    (Selected)

    Show Faces > Transparency

    0.0

    Show Mesh Lines

    (Cleared)

  3. Kliknij Apply.

Wykonaj poniższe zmiany, jako przygotowanie do animacji, które stworzysz w kolejnej sekcji:

  1. Kliknij prawym przyciskiem myszy na pustą przestrzeń w przeglądarce i wybierz Predefined Camera > View From +Z.
  2. Obróć widok o kilka stopni, abyś mógł dostrzec charakter geometrii 3D.
  3. Wyłącz widoczność User Locations and Plots > Wireframe.

7.4. Tworzenie animacji klatkowej (Keyframe animation)

W tej sekcji wygenerujesz animację, która pokazuje zmieniające się pole prędkości na płaszczyźnie Plane 1. Aby wykorzystać periodyczną naturę rozwiązania, nagrasz krótką animację, która może być odtwarzana w powtarzalnej pętli na odtwarzaczu MPEG. Zacznij animację w 61 kroku czasowym (w czasie, w którym przepływ zaczął ustalać się, jako powtarzalny) i zakończ ją na 90 kroku czasowym. 60-ty krok czasowy odpowiada 2/42 s, natomiast 90-ty krok czasowy odpowiada 3/42 s. Z powodu tego, że 60- i 90-ty krok czasowy wyglądają tak samo, 60-ty krok czasowy jest pomijany, aby uniknąć pary sąsiednich identycznych klatek w animacji, kiedy następny krok jest powtarzany w pętli.

  1. Kliknij Timestep Selector   i załaduj 61 krok czasowy.
  2. Kliknij Animation.
  3. W oknie dialogowym Animation wybierz opcję Keyframe Animation.
  4. Kliknij New , aby stworzyć KeyframeNo1.
  5. Wybierz KeyframeNo1, następnie ustaw # of Frames na wartość 28, potem wciśnij Enter, gdy kursor znajdzie się w bloku # of Frames.

    Rada

    Upewnij się, aby wcisnąć Enter oraz, że przed dalszym kontynuowaniem pojawi się nowy numer na liście.

  6. Użyj Timestep Selector, aby załadować 90-ty krok czasowy.
  7. W oknie dialogowym Animation kliknij New , aby stworzyć KeyframeNo2.
  8. Upewnij się, że funkcja More Animation Options jest wciśnięta, aby pokazać więcej opcji animacji.
  9. Wybierz Loop (pętla).
  10. Upewnij się, że przycisk Repeat forever znajdujący się obok Repeat nie jest wciśnięty.
  11. Wybierz Save Movie.
  12. Ustaw opcję Format na MPEG1.
  13. Kliknij polecenie Browse znajdujące się obok opcji Save Movie.
  14. Ustaw opcję File name na ImmersedSolid.mpg.
  15. Jeżeli będzie to wymagane, ustaw ścieżkę lokalizacji do innego katalogu roboczego.
  16. Kliknij Save.

    Plik animacji włącznie ze ścieżką został teraz ustawiony, ale animacja nie jest jeszcze utworzona.

  17. Kliknij To Begining .

    Ta opcja zapewnia, że animacja rozpocznie się od pierwszej klatki.

  18. Po załadowaniu pierwszej klatki animacji kliknij Play the animation .
  • Plik EMPEG zostanie stworzony, kiedy przebiegnie animacja.
  • Odbywać się to będzie powoli, gdyż wyniki dla każdego kroku czasowego będą ładowane i obiekty zostaną stworzone.
  • Aby zobaczyć plik filmu, musisz użyć przeglądarki, aby wesprzeć format MPEG.
Aby uzyskać dodatkowe opcje animacji, kliknij przycisk Options. W etykiecie okna dialogowego Animation Options znajduje się pole wyboru (check-box) o nazwie Save Frames As Image Files. Po zaznaczeniu tego pola wyboru, pliki JPEG lub PPM używane do zakodowania każdej klatki filmu będą zachowywane po stworzeniu filmu. W przeciwnym razie zostaną usunięte.


Jeżeli skończyłeś, zakończ CFD-Post.

  • No labels